3

I've tried most things i've read online to try to fix this issues to no avail but I'll explain exactly what's happening.

I think I accidentally deleted the EFI partition from my Mac which is the root cause of my problem. I had Mountain Lion and Bootcamp with Windows 7 installed. There were a bunch of partitions when I would open Disk Utility and I wanted to delete them so I did. My mac wouldn't even load an OS so I tried to erase everything and reinstall snow leopard back onto it.

When I start the computer the Apple logo appears and then it tries to start the OS installer. A loading bar says "installing" and then it closes out quickly and says "There was a problem installing "Mac OS X". Try reinstalling.

I've tried installing with a disk and a USB drive. Same thing happens.If I go into Disk Utility it shows my 250 gig hard drive with 1 partition "Mac" underneath.

When I verify or repair disk on the main hard drive it says "Partition map check failed because no slices were found."

When I verify the Mac partition it says "Disk utility stopped verifying "MAC" This disk needs to be repaired. Click Repair Disk.

When I try to erase the hard drive it says "Disk Erase failed. Couldn't unmount disk."

Any help would be appreciated. All I want to do is just install a new OS.

  • Did you try to change the format of the disk when you tried to delete it? If so, try to erase the disk without changing the format. – jmh Sep 13 at 21:23
  • No. I don't change anything. I keep it on Mac OS Extended (Journaled). But I've also tried to erase with every other format. It always says "Couldn't unmount disk." – Jaymie Redman Oct 6 at 22:54

You must log in to answer this question.

Browse other questions tagged .