1

I am trying to update my Mac OS Mojave which is currently running 10.14.3. Now the latest update is 10.14.6. I tried updating via system preferences but it gave me an error "This volume doesn't meet the requirements". I tried downloading and installing combo update from here: https://support.apple.com/kb/DL2010?locale=en_US It gives me error "The package has an invalid signature" on installation while installing after restart. I tried downloading and installing 10.14.4, but it gives the same error "The package has an invalid signature" during installation.

I have been stuck here for days. I really want to update my mac. Please help.

-- diskutil list output --

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *121.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         121.1 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +121.1 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD            97.9 GB    disk1s1
   2:                APFS Volume Preboot                 42.0 MB    disk1s2
   3:                APFS Volume Recovery                517.1 MB   disk1s3
   4:                APFS Volume VM                      1.1 GB     disk1s4

My security and privacy pane is also not loading. Can the update installation have something to do with it?

  • Could you run Terminal using the command diskutil list & copy paste the result into your question - if you select the paste afterwards & hit ctrl/k [not cmd, ctrl] it will format it better for here. – Tetsujin Sep 13 at 19:28
  • Post updated with the diskutil list output. Please help :) – Muhammad Sadiq Alvi Sep 14 at 20:06
  • Check the downloaded file's integrity: its size should be 3,368,449,919 bytes, and running shasum -a256 on it should print "61fc98e6b1ec84822ea7513c1223fb4b8e4681b1f076dd4a675238847a95e3e9". – Gordon Davisson Sep 14 at 21:25
  • @GordonDavisson The combo update is downloaded from this official link: support.apple.com/kb/DL2010?locale=en_US and almost has the same size. Please help – Muhammad Sadiq Alvi Sep 15 at 12:54
  • My security and privacy pane is also not loading. Can the update installation have something to do with it? I have updated the post with the screenshot of it. Please check it out. – Muhammad Sadiq Alvi Sep 15 at 13:00
1

It sounds like it could be a corrupt plist file or something else entirely. You didn't happen to remove any certificates from Keychain did you (accidentally)? Apple uses those for verifying code signatures.

One simple idea to try is to create a new admin account on your computer. Login and see if you're able to update the OS from that account. You can delete that account after the system if updated, or at least, you've now isolated the problem to a single account.

If that fails, I might try just re-installing macOS from the recovery partition. This will overwrite the system files but shouldn't affect anything else.

  • Tahnks a lot. After all the tries re-installing the OS worked :) – Muhammad Sadiq Alvi Sep 16 at 0:19
0

If no one can help get to the bottom of why the installer either is failing or your current install is broken, you have a very clear path forward.

  1. Back up all your data - Time Machine does very well in this case getting all the valid data off the machine and onto a different drive and different partition.
  2. Boot to internet recovery and erase everything - run the installer.

If that step above fails, you know you have a hardware issue - drive / SSD / logic board. If it works, you then have the current OS installed cleanly and can bring back your apps and accounts.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .