I have MacBook Pro (13-inch, 2016, Touch ID model), and I've been on macOS 10.15 Catalina developer beta since June without any issues. However, since updating to the latest beta, I have several major issues:

  • Item dragging is not working. I've tried three-finger drag in Finder on built-in trackpad and using Logitech MX Master mouse. It simply selects the file and doesn't move the file as I move the mouse cursor.
  • Safari hangs very often, especially when editing text. I have to Force Quit it every couple minutes. I've tried disabling all extensions and clearing Caches from Develop menu. (FWIW Chrome works perfectly good).
  • Same in Mail app, when I try add a new mail account. When I edit texts in Mail Preferences window, the app hangs.
  • I can't download any new apps from the Mac App Store. It starts downloading process but nothing happens, stuck at 0% progress.

It looks like all these problems appeared after I updated to beta 8. I don't have any previous backups.

I've tried restarting my Mac, resetting SMC and doing some cleanup with CleanMyMac but no luck. What can I do, preferably without restoring my system?

  • 2
    I, too, have been having these exact same issues. Drag/drop isn't working, lots of app hangs, etc.
    – mikesir87
    Sep 16, 2019 at 19:19
  • 1
    I am also having same issues and my touch bar is not turning on at all with all other issues like file drag and safari crash. The process for touch bar is not listed in the activity monitor. I cleard NVram and posting this comment from safe mode but nothing worked. waiting for another update
    – Usama
    Sep 17, 2019 at 6:32
  • 1
    Curious... have either of you lost the ability to use external monitors? I can connect via HDMI, but can't use my Thunderbolt connections.
    – mikesir87
    Sep 17, 2019 at 13:20
  • 1
    Just same issues here. Specially not dragging is been a pain
    – Fischer
    Sep 18, 2019 at 7:07

3 Answers 3


I was having the same issue, and I just reinstalled the beta by going here: https://developer.apple.com/download/ then clicking "Install Profile" on Catalina. Then went to software update, and it started downloading Catalina again. Everything's fine now (no hanging, dragging works, etc.).


Beta software are supposed to be for testing purposes. Specifically BetaOS is released publicly for tech enthusiasts only and that's absolutely not recommended to install on anyone's primary machine.

It seems like Apple is trying to force use of firewall which is creating trouble for Internet related apps (Chrome, Mail, Safari). You can investigate with following.

0) Fist Check your DNS settings. Sometimes your ISP provided DNS sucks. Use Google DNS (, etc)

1) Check Firewall and proxy settings in your Settings app.

2) You can investigate your hosts file sudo nano /etc/hosts (Careful: You need to know what you're doing.)

3) Just assume Apple is outdating your system :D

4) Chances are Apple enabled several Debug Logs to test the Beta 8. they'll turn it off with final release. Investigate using Console.App

5) You can further investigate using Activity Monitor.app (Both are found under Application > utilities)

That's my best guess :)

  • Thanks for your reply, but unfortunately, your suggestions didn't help - I've checked Firewall and proxy settings (they are both disabled), as well as hosts file (three rows for localhost) and DNS settings (it just points to the router on current WiFi network). Sep 13, 2019 at 12:18
  • Like Naveed said, it is "beta" software. So presumably you have a backup of your system that is non-beta or it is on a system that you don't care about and can just wipe and start over. Sep 13, 2019 at 12:50

Upgrading to 19A573a has fixed the issue for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .