My Macbook Air 2011 could connect to a 5g wifi network before but now, my Macbook won't connect and it showed an error message that says could not join wifi network. The wifi network worked fine for other devices eg. my phone and my MacBook could connect to the same wifi before. My operating system is macOS 10.13.6. I would appreciate it if there would be a fix to that.

  • Try forgetting that network so that it asks for a password again.
    – lhf
    Commented Sep 12, 2019 at 15:32
  • Is it just that particular network or is it all 5G networks?
    – Allan
    Commented Sep 12, 2019 at 18:38
  • Well, sometimes I cannot connect and sometimes, without doing anything, it somehow just worked. Commented Sep 13, 2019 at 5:46
  • Ok, now my computer says that the password is wrong though the password that I entered is correct Commented Sep 15, 2019 at 7:54

1 Answer 1


As you mentioned in your comment, it works sometimes. Then, I would recommend to flush DNS of your MacBook and try it again as a first step.

Flush the DNS cache by typing:

  dscacheutil -flushcache

Forget network and try to connect it back.

Other professional steps to know more on it:

Run Apple Diagnostics:

If you still haven't solved your Wi-Fi worries you could use Apple Diagnostics to check for Wi-Fi or network issues.

To do so follow these steps:

  1. Disconnect all external devices (except the keyboard and screen).
  2. Shut down the Mac, then turn it on while pressing and holding D.
  3. When you see the screen asking you to choose your language do so, then watch as the progress bar indicates that your Mac is being assessed. This takes 2-3 minutes.

If problems are identified, Apple Diagnostics will suggest solutions.

Reset your SMC, PRAM or NVRAM

Reset the PRAM and the SMC (System Management Controller) is worth a try. This process is covered here: How to reset your Mac's NVRAM, PRAM, and SMC.

I suggest you try this step as a last option.

However, flushing DNS should work if your network is working sometime then.

  • Thanks for the answer, I tried flushing my DNS and it didn't work, I tried apple diagnostics and it also said nothing. I did not attempt to reset the NVRAM and I also tried to connect to the wifi in another user and it also did not work. Now it won't connect to the 5G wifi at all and now the computer says that the password is wrong even though I copied the password down form the router config page. Please help. Commented Sep 14, 2019 at 13:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .