2
  • Hardware: Keil LPC1768 development board.
  • macOS 10.14
  • Flashing/Programming device: Keil ULINK-ME (USB-JTAG adapter)

I have tried the VS Code extension platformIO and mbed Studio(standalone), but none seem to find the connected board/flashing device ULINK-ME.

I have tried the same on a Windows VM running on VMware Fusion with the Keil IDE, that does all of the flashing stuff and that worked, but I would really love to get it natively running on macOS.

macOS seems not to mount the board under /dev/tty.* or anything like that, like probably Linux would do.

If any questions arise about my setup, please comment, so that I can update this post.

I appreciate any proper constructive help. Best regards.

1

Apparently it is possible. After a long conversation on the platformIO community forum I was helped. here is the topic click me And here is a link to a working Blinky(blinking LED) example that's doing all of the configuration stuff needed to upload it properly to the device. click me - Github

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .