0

I've installed Eclipse CDT and GNU MCU Eclipse plugin and finaly GNU Tools for ARM.

I've created a Hello World project, which builds ok - but, debugging seems not to work with GDB. Configuring GDB Aborting configuring GDB.

I have set the proper paths to arm-none-eabi-gdb.
I have signed the arm-none-eabi-gdb (with the same certificate that I used to sign GDB installed via brew the day before - and it worked).
I have also tried running Eclipse as root from command line.

Nothing helps.
The message is "Configuring GDB Aborting configuring GDB".

What to do?

  • Seems to me you do not have all software/hardware required - see the explanations on this page: gnu-mcu-eclipse.github.io/debug/install. One more word: do not rush to install/uninstall mac osx usb drivers - FTDI USB drivers are already part of mac osx. On mac you just need to add libusb vers>1.0 (I used this with openOCD, other servers may not use it). – Yoan Sep 12 at 11:54

You must log in to answer this question.

Browse other questions tagged .