2

I've seen lots of commentary repeating the end result "32-bit apps are no longer supported."

But that leaves many unanswered technical questions. Does 10.15's XNU still recognize 32-bit binaries? Does 10.15's dyld still recognize them?

  • 1
    What do you mean by recognise them? Run them or see they are 32 bit and say can't run them – user151019 Sep 11 at 22:24
  • Also, which practical problem are you trying to solve here? – nohillside Sep 12 at 5:25
3

Does 10.15's XNU still recognize 32-bit binaries?

They are still recognized as executables, but attempting to execute one results in a "bad CPU type in executable" error, just as if you were trying to run an PowerPC or ARM binary (and different from an incomprehensible file, which will result in an "exec format error" error).

Does 10.15's dyld still recognize them?

Recognize them as what? It'll recognize that an .dylib with a 32-bit slice is a library, if that's what you mean, but it'll refuse to load it into a 64-bit process.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .