2

I have a Mac running the latest (10.14) along with an iPhone also running the latest (12.4). I also have a couple iPads (12.4). I also have a Watch.

I think I have 7 podcasts that I subscribe to via iTunes on the Mac and Podcasts on the iOS devices. I tend to listen to them on the iPhone but sometimes listen to them on the Mac and very rarely on one of the iPads.

Lets just pretend there is just the Mac and iPhone if that simplifies things.

Long story short, things do not stay synced very well at all. Right now, my iPhone has two copies of two episodes.

I'm wondering if perhaps the "downloads" should be set on the Mac only and off everywhere else so that the Mac will download the episods and then sync them to the other devices. I've tried lots of various settings and I didn't keep track but I think I tried that but I'm not sure. I think I also tried subscribe on the Mac and don't subscribe on the iOS devices but that causes the whole channel to disappear.

The basic question is -- how do you get your Podcasts to sync up? Or... perhaps I should abandon iTunes / Podcasts and use a different set of apps? Listening anywhere besides the iPhone is very secondary since it is always with me and I can control it from my watch. But it just seems like a relatively simple problem to solve, I'm surprised its this hard to get things to work right.

  • Are all these devices using the same Apple ID? – fsb Sep 11 at 13:55
  • @fsb yes. And all should be logged in – pedz Sep 11 at 15:15
  • Do you have Settings -> Podcasts -> Sync Podcasts turned on (and the equivalent for macOS)? – fsb Sep 11 at 15:43
  • @fsb my iPhone has that set. On the Mac, I see Preferences => Store => Sync Playback information across devices as well as Sync podcast subscriptions and settings which are both checked. Also on the Mac, per device has Podcasts and Sync Podcasts plus Automatically Include and I have all unplayed picked. – pedz Sep 11 at 23:43
1

I suggest starting over -- that is

1) unsubscribe from all podcasts, and restart all devices. Then,
2) do Settings -> Podcasts -> Sync Podcasts and/or Preferences => Store => Sync Playback as described in the notes below your question. Then,
3) Plug in each device to your computer with iTunes open, select the device as shown in the first image, go to the `Summary` section for that device and make sure `Sync with this iPhone over Wi-Fi` is checked.

enter image description here

4) Finally, subscribe one at a time just from one iOS device only
5) After the above is working, subscribe from the other devices

I say this first because I've been subscribing to podcasts using iTunes on my Mac and my iPhone for about a decade without problems like you describe, and in the last several years I never even go to iTunes on my computer anymore. I just subscribe to new Podcasts from my iPhone and things sync fine. Second, my experience is "starting fresh" tends to solve most computer-related problems.

  • I pretty much agree... I wish I could save, even if it is "by hand" the list of episodes per podcast that I've already watched. I know I've added the same podcast to the Mac and iPhone at different types. I think I want to just add and control things (in my case) via iTunes on the Mac and then "sync" and see how that looks on the iOS devices. It may take a few days to get my nerve up to do this :-) – pedz Sep 12 at 22:30
  • In the past two weeks, I have deleted and added my podcasts in various ways and there are always problems. I never tried "Reset Identifier" that is offered in iOS Settings => Podcasts. But, it never really worked. What I am using at this point is "Overcast". It has no MacOS application but I switched to it because it has more features in iOS and more "Shortcut" features as well. It seems very stable and solid if you want to give up the MacOS option -- which wasn't really working for me anyway. – pedz Sep 30 at 22:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .