12

I have an external monitor connected to a Macbook. The current behaviour of the dock is that it jumps from one display to another whenever the cursor is at the bottom, which I find quite annoying.

Is is possible to change this to either of the following?

  • Show the dock permanently on the primary display only
  • Show the dock permanently on both displays
1

2 Answers 2

8

You can prevent the dock from moving:

defaults write com.apple.Dock autohide-delay -float 999 && killall Dock

This will keep the dock on your primary display, unless you keep your mouse at the bottom of another display for more than 999 seconds.

This works with separate spaces.

Based on the responses to my post on the apple forums.

7
  • 3
    While this seemed very promising i just tried typing that command in the terminal. It seems to have reseted my dock but it did not work; i still can move the dock to another screen by mouse placing the cursos at the bottom
    – damuz91
    Commented Dec 2, 2022 at 16:55
  • 1
    I checked again by reducing the time to 1 second and back to 999 and it works as expected, my source was my post from the apple forums: discussions.apple.com/thread/253716507 Did you really kill the Dock process? Have you tried rebooting? Tested on 13.0.1 (22A400).
    – derbroti
    Commented Dec 3, 2022 at 13:42
  • Thanks for checking. Yes, i tried first the command with 1 and i saw how the dock got hidden and then back. Then i tried placing the mouse in a different screen and it changes. Then i tried the command with 999 value and same behaviour. Tried on OS 13.0 Macbook pro M1 Max
    – damuz91
    Commented Dec 4, 2022 at 16:18
  • I can now confirm that it does not work with all screens? With my Samsung LU28R554 (connected via displayport through a thunderbolt dock) it works, with a 4K Dell from work it does not - I tried DP and HDMI, nothing worked on the Dell...
    – derbroti
    Commented Feb 16, 2023 at 18:34
  • did not work for me either..
    – Bersan
    Commented Aug 16, 2023 at 9:40
6

You can achieve the first, lock it to a single display - though it will entail a change in working practice.

System Prefs > Mission Control
Uncheck "Displays have separate Spaces"

Your Spaces/Desktops will then always move as a pair, locked together.

enter image description here

Then use System prefs > Displays > Arrangement
You can drag the menu bar representation to define your primary display. The Dock will remain always on this display.

enter image description here

As the Dock is always shown either on the active Space/Desktop in single-screen, or only on the primary display of a multi-screen setup, there's no way to make it appear on two displays simultaneously.

6
  • 4
    The problem with setting ""Displays have separate Spaces" is that it means I'll only have a menu bar on the primary display. For me, this is even more annoying than the dock jumping around.
    – Dónal
    Commented Sep 11, 2019 at 14:48
  • You didn't mention that in your question. Personally I hate 'displays have separate spaces' & have done since it was introduced. I've had dual monitors on Macs for about 20 years without ever needing that ;)
    – Tetsujin
    Commented Sep 11, 2019 at 14:51
  • Presumably you've just learned to live with the Dock jumping around, or it never bothered you?
    – Dónal
    Commented Sep 11, 2019 at 15:02
  • It doesn't go anywhere. It stays on my primary screen, right where I want it to be. It's separate spaces with mis-matched screen pairs, 2 menu bars & 2 docks that drive me bananas. I want one, right where I put it… muscle memory wins every time. I imagine if you use a track pad, it would be a long reach, but I never use a trackpad either. I'd call them 'the devil's work' but I don't think that adequately describes how bad I think they are ;)
    – Tetsujin
    Commented Sep 11, 2019 at 15:06
  • does not work for me on Ventura 13.2
    – Bersan
    Commented Aug 16, 2023 at 9:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .