4

I have this issue where my selected audio device will reset to Digital Out after I restart.

I have searched online and found some people suggesting deleting some configuration file for older versions of Mac OS, but the file doesn't exist in my computer.

Anyone knows what file holds these settings so I can see if it's a permissions problem?

Or if anyone knows what the true solution is please let me know.

thanks.

  • 1
    Please provide a lot more detail. You've tagged High Sierra -- what exact version are you on? What Mac model? Any external audio hardware? Any third-party drivers? What do you want your audio config to be? – benwiggy Sep 15 at 11:32
  • the default behavior is stay in the selected audio device on reboot. I have many Macs and this is the only one that this happens in after reinstallation and cloning of high Sierra. – Eweie Sep 15 at 21:57
2
+50

If the audio device you're using is always connected, please try these instructions (relevant portion below, although there are some other suggestions in that post that could be worth trying).

However, keep in mind that if the device is disconnected when your system starts, it will revert to the system default. (It is also possible, that if you are loading certain applications on startup, that they are resetting the preferred default, but we'll need more details on your system configuration/startup items in this case.)

You could also, depending on your situation, use an AppleScript method to create a one-click type approach to your audio selection.

Suggested first attempt to solve this issue:

Go to /Applications/Utilities and open Audio MIDI Setup. Select the device you want to use, click the gear, and then Use this device for sound output.

enter image description here enter image description here

  • It's a virgin installation of high Sierra, albeit cloned from another drive. there is no third party sound drivers/devices. the default behavior for Mac OS is to stay on the selected sound device on reboot. this is all I want. – Eweie Sep 15 at 21:59
  • @Eweie what happened when you tried the above? You can do the same thing, just choose whichever sound device you want. – dxdc Sep 15 at 22:02
  • does not work and is not different than just selecting the device form the dropdown. – Eweie Sep 20 at 8:16
  • OK, @Eweie, then I suggest we do a simple test to see if the issue is with your audio device itself or with your preference not being saved. Try installing Soundflower: rogueamoeba.com/freebies/soundflower. This will create several new audio devices inside Audio Midi Setup (2-3 of them). Choose one of those and restart. Does that setting persist, and if so, the problem is just with your audio device? What type of audio device are you trying to choose and have persist? Please post a screenshot. – dxdc Sep 20 at 12:55
1

You can try reset your SMC and NVRAM. It will bring your system to default settings overriding any plist entry which is causing unwanted device to take priority.

Reset SMC

Shut Down your Mac.
Press Shift + Control + Option + Power button at the same time. 
Release all keys and the power button at the same time.

6) Reset NVRAM

Shut down your Mac.
Press the power button.
Before the grey screen appears, press the Command, Option, P, and R keys at the same time.
Hold the keys until your computer restarts and you hear the startup sound a second time. 
Release the keys.
  • does not do anything. – Eweie Sep 20 at 8:16
0

The answer is that the file in question is com.apple.audio.SystemSettings.plist and it is stored /Library/Preferences/Audio in my case this file and folder did not exist. clearly indicating a very severe permissions problem on my library folder. the audio settings panels never wrote this file therefore settings would not stick on reboot.

The way I found out was by installing high Sierra on another drive to see if the settings got saved and dismiss or confirm a hardware issue.

  • Also. once I realized this, I used the migration assistant to transfer all my settings and applications to the new high Sierra installation that was in a hard drive, once done I cloned it back to my ssd. the problem did not recur. I have an idea what I did to ruin the permissions on a virgin install of high Sierra originally but I can't say exactly what this was. all I can say is that this is not something that would normally happen to someone and I'm disappointed an easier fix wasn't suggested by the community. I could have tried copying the folder to the original install but alas. – Eweie Sep 20 at 23:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .