0

I tried to check Unlimited scrollback option in the iTerm2 settings, however, it doesn't seems to be applied for longer outputs (say couple of thousands lines). The output gets truncated so I can scroll up just to the last 1000 lines or so. enter image description here

I am running Mojave with ZSH 5.7.1 installed, the HISTSIZE is set to the 100 000 lines (however I don't think that matters to the terminal emulator). So is there something I am missing? Thanks for help

  • Actually I found out it's working for all tabs other than the first one. Which means the first tab still has the limit. Weird :-/ – Petr Mensik Sep 19 '19 at 15:34
-1

Unlimited scrollback might not work properly as expected, I am not sure why but it is may be because of the config of zsh.

So, I would suggest you specify the scrollback lines like 10000 (in my case) in the textbox and unchecked the "unlimited scrollback buffer" option

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .