0

This is going to be a long story, but please bear with me...

I'm trying to recover a MacOS X partition that got lost on my Seagate HD. This HD was dual booted using BootCamp with Windows 10. I originally had Linux on this HD too, but eventually deleted it and used BootCamp to put on a Windows 10 install. (This is all on a late 2011 MacBook Pro). I was actually trying to migrate everything over to a solid state drive by using SuperDuper! and Winclone, but something went wrong in the whole process, and all of a sudden I couldn't boot into the MacOS operating system any longer (gave the prohibitory sign). To make things worse, the system couldn't actually find the MacOS partition either.

So I used Apple's internet recovery to at least get a bootable MacOS X going and put the SSD into the MacBook Pro. I then put the Seagate HD into a Sabrent external USB adaptor so I could see what was going on. After booting into MacOS and running terminal, I see this:

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh SSD           499.2 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

/dev/disk1 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:          Apple_CoreStorage Macintosh HD            336.8 GB   disk1s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk1s3
   4:       Microsoft Basic Data BOOTCAMP                110.0 GB   disk1s4

/dev/disk2 (external, virtual):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS                        +336.5 GB   disk2
                                 Logical Volume on disk1s2
                                 0F8A5999-AA3A-42E3-AB53-260295D99FA1
                                 Unencrypted

So you can see that it knows the MacOS partition is there (disk1s2), but it won't mount, DiskUtility has no idea what is on the disk (it's greyed out), and I obviously can't browse into it to get any files. I don't know why it lists an external virtual volume as well...this seems to be the MacOS partition as well - i.e. it looks like disk2 is the same as disk1s2. I ran First Aid on it through DiskUtility, but got:

File system check exit code is 8.
Restoring the original state found as unmounted.
File system verify or repair failed.

If you try and run DiskUtility through Recovery on the entire drive, it says something's wrong and that it may be corrupt.

Using the command fdisk /dev/disk1 gives:

Disk: /dev/disk1    geometry: 60801/255/63 [976773168 sectors]
Signature: 0xAA55
         Starting       Ending
 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
------------------------------------------------------------------------
 1: EE 1023 254  63 - 1023 254  63 [         1 -     409639] <Unknown ID>
 2: AC 1023 254  63 - 1023 254  63 [    409640 -  657891312] <Unknown ID>
 3: AB 1023 254  63 - 1023 254  63 [ 658300952 -    1269536] Darwin Boot 
*4: 0C 1023 254  63 - 1023 254  63 [ 659570688 -  214843392] Win95 FAT32L

Using the command gpt -r show disk1 gives:

gpt show: disk1: Suspicious MBR at sector 0
      start       size  index  contents
          0          1         MBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34          6         
         40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
     409640  657891312      2  GPT part - 53746F72-6167-11AA-AA11-00306543ECAC
  658300952    1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
  659570488        200         
  659570688  214843392      4  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
  874414080  102359055         
  976773135         32         Sec GPT table
  976773167          1         Sec GPT header

I think this might be similar to an issue someone was having here:

Prohibitory sign on boot after Sierra update, can't mount disk anymore

but I'm not sure, so I thought I'd post this.

Any help that anyone can provide is greatly appreciated!

  • Hi, @kanomath. I installed High Sierra on the SSD. How can you tell it's the MBR? Is it because of the gpt output? – Dave Sep 9 at 13:50
  • No. I updated it to Mojave. – Dave Sep 9 at 14:37
  • Mojave usually doesn't support MacBook Pro 2011 (early & late)! So it's difficult to say how a High Sierra boot volume handles your patched Mojave boot volume. First I thought it's the MBR on the external disk (macOS & Bootcamp) – klanomath Sep 9 at 14:49
  • I understand and I've thought about that, but whenever I recount the events, even when the Seagate was the only HD when everything happened, the system wasn't even seeing the OS X partition as bootable then. So either way, there's an issue I hope can be solved. Would using the gpt command in terminal to delete the partition and then re-assign it with the same partition type GUID write the correct information into the MBR? I'm open to doing a TeamViewer session if you are! I'll be travelling Tuesday and Wednesday, so maybe we can coordinate something for later in the week? Let me know. – Dave Sep 9 at 18:50
  • Where are you right now (time zone)? I'm living in Berlin (MESZ=GMT+2). – klanomath Sep 9 at 18:57

You must log in to answer this question.

Browse other questions tagged .