After I had got a new Samdung T5 external SSD (2 TB) I had formatted it with DiskUtilit, created 3 partitions and could make it work: 1. TimeMachine Backup to partition 1 2. Some important data backup in partition 2 3. Start up with macOS Mojave in partition 3

The partition which came with the SSD (Setup utility) was untouched.

After my MacBookAir (early 2015) ran out of power and went to sleep mode, restarted the computer. Since then only the partition with Setup utility is visible. I am not able to mount any other partition nor can I see them in the diskutil in Terminal mode.

Can you help me? What makes me frustrated is that the SSD was working fine for several days, but now all data seems to be lost or unaccessible.

1 Answer 1


Probably a format issue. There should be nothing left that was on the disk when new! Format the drive completely in Mac OS Extended (journaled), completely, everything! Then partition it in the three partitions. Then install Mojave in one partition (the format will be changed only in that partition).

  • I would use APFS rather than HFS for a SSD
    – mmmmmm
    Sep 8, 2019 at 18:22
  • Your answer doe not help. The format was fine. I had fortmatted the different partitions using Disk Utility. Only after a power outage it is not readable at all except for the part which contains the setup program. I had done what you suggested, and it had worked for appr. 2 days. I can't believe I am the only one with this issues, and there is still no solution. There was data on the SSD which is gone now! Sep 9, 2019 at 11:04
  • You did misunderstand my post: the formats are different.
    – LexS
    Sep 10, 2019 at 10:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .