1

Just upgraded to High Sierra on my MacBook air 2011. Unfortunately my Excel keyboard shortcuts have stopped working - I was using Karabiner to map F2 (usual windows edit key) to use ctrl u, which makes it easier to use excel. I had to also move to Karabiner-elements, as the version I was using isn't compatible with High Sierra. I have attempted to write a .json file to setup a complex_modification, but it doesn't seem to work - the event viewer just shows the f2 key Im using MacOS 10.13.6 Excel for Mac 2011 version 14.7.7 Karabiner Elements 12.6.9

The code I wrote is:

{
    "title": "F2 change to Ctrl U",
    "rules": [        
        {
            "description": "F2 change to Ctrl U",
            "manipulators": [
                {
                    "type": "basic",
                     "from": {
                        "key_code": "2",
                        "modifiers": {
                            "mandatory": [
                "fn"
                ],
                "optional": [
                         "any"
                        ]
                        }
                    },
                     "to": [
                        {
                          "key_code": "u",
                          "modifiers": [
                            "left_control"
                          ]
                        } 
                    ]
                }
            ]
        }
    ]
}

What am I missing? Thanks,

1

I just used the "customize keyboard" in the Tools menu and it works fine...

This image shows it being set up:

enter image description here

  • Hi Mike - My version of Excel doesnt seem to have the same options – Mike Sep 9 at 10:22
  • sorry timed out- My version of Excel doesnt seem to have the same options - I don't have the search under commands & Ive scrolled through all the options but cant see a relevant edit entry. – Mike Sep 9 at 10:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .