1

I decided to stick to the safest approach to make copies of my backups. In other words, my Mac backs up everything to one external drive and then I copy that entire backup directory to the second external drive.

I researched and found this command to be good for any files to be moved and synchronized from source to destination directories:

rsync -av --delete /Volume/Drive1/MyPictures/ /Volume/Drive1/MyPictures

That worked pretty well for any directory I store on the external hard drive except for Mac's backup directories. Running this causes an error:

rsync -av --delete /Volume/Drive1/Backups.backupdb/ /Volume/Drive1/Backups.backupdb

failed: Operation not permitted (1)
rsync error: some files could not be transferred (code 23)

Any suggestions how to address this? I tried rsync -rtb and got the same error. Copying manually using Finder also alerts with The operation can’t be completed because backup items can’t be modified.

3

Funnily enough, starting with macOS 10.12 the Finder has been granted special powers to perform an 'exact copy' on Time Machine archives. Use the Finder and only the Finder to give your .backups new homes, because Finder will maintain not only all permissions and metadata but either maintain or translate inode references for each item in the backup.

  • That is really interesting. I never heard about that. Do you have any references where I could learn more (maybe also add to answer)? – n1000 Sep 8 at 19:39
  • support.apple.com/en-in/HT202380 gives instructions. Mike Bombich (the Carbon Copy Cloner guy) discovered that little tidbit out a while ago, and had mentioned it on his site. – BentonQuest Sep 9 at 7:04
  • Super interesting. I really think you should edit your answer to include this link along with some more instructions. Thanks. – n1000 Sep 9 at 7:39
2

You can't really. Time Machine uses hard links for directories and rsync (especially the one with macOS) does not support this.

However in this case the best way to get two Time Machine is to select two disks as Time Machine disks in Time Machine Preferences. To create the second Time Machine partition you can use Disk Utility to copy the existing Time Machine partition.

  • Have you tried sudo? – Theologin Sep 8 at 2:27
  • The issue is not permissions but the disk structure so sudo does not matter here. Although as an attempt it should be tried to copy all the files – user151019 Sep 8 at 10:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .