apologies if this is inappropriate. I've posted this twice on r/applehelp on reddit and got no help, so I'm hoping someone here might be able to help me out. Copy-pasted from there:

Background: back in 2015 I successfully installed Windows 10 on my iMac (iMac 21.5-inch mid-2011, 2.5 GHz Intel Core i5) via Bootcamp, using a Windows 10 license (burned onto a CD) I got as a gift. I'm pretty sure I didn't use a bootable flash drive, but as of now that would be necessary as I've replaced the optical drive with a SSD. I had some minor and common issues at first (such as having no audio), but eventually those were resolved and the partition worked perfectly. I no longer have this partition and am interested in installing the OS again, but I don't remember how I did it back then.

Issue 1: Boot Camp Assistant claims 'Windows 10 is not supported on this Mac'. Support software is already installed onto a flash drive. How would I go about installing Windows 10 if it's unsupported, and how did I manage to do it in the first place all those years ago? Did something change between then and now? I have tried some tricks that supposedly allow you to install the OS on an unsupported machine but those ultimately failed.

Issue 2: A little while ago I tried using Parallels and it ran rather well, except that I couldn't use my Windows license key because it didn't register my computer as being the same one where I previously installed Windows. If I manage to install the OS again, would it accept my license key again?

Any help is appreciated.

Boot Camp Assistant only shows support for Windows 7 and 8

USB with Windows 10 installation files

UPDATE 4: I managed to revert my shameful and convoluted partitioning mistake by wiping out disk0 and reinstalling macOS + restoring a backup. Once everything was back the way it was, I used Boot Camp Assistant to create a partition for Windows (BOOTCAMP). A new problem arose, however, when the computer rebooted and all I got was a black screen with 'No bootable device found'.

Upon pressing Option while restarting, I understand that there should be a legacy Windows option and an EFI Boot option. Because my iMac no longer has an optical drive and I am using a bootable USB, only the EFI option appears. I now believe this is the source of most problems I have come across. Something about the disk becoming a hybrid MBR-GPT and Windows (EFI Boot) not recognising it as GPT? I will look more into this and update.

1 Answer 1


I’m assuming you have a bootable Windows 10 pen drive with Mac drivers.

I didn’t read any tutorials for doing it, the following is what I would try given your circumstances (and considering I’ve already installed Windows a few times on a few different Macs for gaming).

I would try to go on with the Bootcamp Assistant even though it says Windows 8, follow everything to the end, and ignore all the steps you don’t need, just so it creates the partition you need.

Windows 8 drivers could work on Windows 10, but if you already have drivers, ignore it too (leave it unchecked). Do not insert or let the assistant erase or do anything to your bootable pendrive.

Then when the Mac reboots, insert your pen drive with the Windows installation. If your Mac doesn’t automatically boot the pen drive, reboot again holding the option key and select the pen drive.

Install Windows normally on the partition created by the Bootcamp Assistant, and then install all drivers manually in case it doesn’t automatically do so.

  • Hey there, thank you for your fast response. I recalled having made a copy of Boot Camp Assistant that allowed me to proceed without an optical drive so I loaded that up. I had some issues with the Assistant (got stuck halfway through) so I manually created an MS-DOS (FAT) partition on Disk Utility. Rebooted pressing Alt and an EFI boot option came up. I think I had the wrong version burned onto the USB though because it wouldn't recognise my key, so I'll try again and see if anything changes.
    – Marilia EK
    Commented Sep 7, 2019 at 6:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .