My boyfriend and I share location thru Messages and Find My Friends.

I used to be able to see either a purple or gray arrow in settings whenever my location was checked...but not anymore. I just tested it again and had my sister locate me...the arrow appeared in the status bar, but the only purple arrow in settings was under system settings. And, sometimes when I don't allow location access in Messages and Find My Friends, people can still locate me.

Basically, I want to be able to see indicators when someone has checked my location, and I want to be able to disable it altogether when I don't want my location shared.

What do I need to do to make it work this way?

  • Firstly, welcome to Ask Different! :) I hope you come to find this site has a lot to offer! In case you haven't already, it's worth taking the time to read the tour. In the meantime I've edited your question to clarify it somewhat. All the best!
    – Monomeeth
    Sep 6, 2019 at 22:54

1 Answer 1


For seeing the icon indicator when someone checks your location, you need to go to Settings > Privacy > Location services > System services (all the way to the bottom). Then go to the bottom again and check “show status bar icon”.

Please note that this will make the indicator show whenever any of the system location services use your location, not necessarily when someone checks your location on Find my friends. You will probably see the icon very often and it might rarely be caused by Find my friends.

The purple and gray arrows can be seen on the same page, by the name “location sharing”. You can also disable it there so people won’t see you, but it’s better to enable or disable it directly on the Friends app.

For temporarily disabling your location on the service, open the Friends app and tap your name. Then enable or disable “share my location”.

If your location indicator on the map is red, you can’t be seen by your friends. If it’s blue, then the friends you are sharing your location with can check your location.

The message your friends get when you disable sharing is the same as they would if you didn’t have an internet connection: “location unavailable”.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .