1

Im using RDP on a macbook and imac to access my home desktop and works perfectly from my workplace and etc. I also set it up on my partners computer (also macbook) and when we test it using our home network and my private hotspot it works perfectly.

I have configured the router to allow remote connections to our home network everything along those lines.

Here's the problem, I advised him to test it outside at the local library network and it will not work on his specific macbook, when he says its not working i try from my macbook and imac and it works, even tried it on a PC at work just to make sure everything was right. Username, passcode and IP address are correct. We keep getting the error code 0x204.

What could prevent him from using it when it previously works when tested at home???

  • His mac has never worked outside of the home with rdp? maybe the library has blocked remote access. Have you tried your macbook at the library? Why don't you take his macbook to your work and try it. – historystamp Sep 6 at 20:43
2

"...at the local library network..."

Most likely the library's firewall/router appliance blocks RDP. This is a good security measure to keep bad actors from attempting to take control of compromised PCs inside the library's public net, as well as keeping bandwidth down from users who should be using the library net for library-related activities such as database searching, etc. I bet a port scan will show other blocked protocols as well.

We lock our network down tight where I work.

  • Yup. Local libraries I've used (in the US) always have overly restrictive settings. I've been unable to use SSH, VNC/RDP, and VPNs when on a library Wi-Fi network. Try a local coffee shop or restaurant and see if they work. (Sadly one of the things that used to work was Back To My Mac, before Apple killed it.) I'd also try Screens 4 with Screens Connect and Jump Desktop with Jump Desktop Go to see if either of those work. I've had good luck with Jump Desktop especially. – TJ Luoma Sep 6 at 21:17
  • yeah, that was definitely the issue. Thank you! – Spicehead-julio Sep 7 at 21:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .