When using Apple’s Mail.app, a mail message offers a pop-up menu to reduce the size of an enclosed image.

➥ How can I do the same when shooting and sending photos from within Messages.app on an iPhone?

Currently my iPhone sends out huge 3.3 meg files where 120K would do.

  • Hi! I find wikipedia links slightly odd. Is there some reason ? I assume that anyone answering or looking for answers knows what they are. – ankii Sep 6 at 19:56
  • 1
    @ankiiiiiii I don't make that assumption. Newbies are born everyday. When I trek over to unix.stackexchange.com to read about BSD, what many authors there consider to be mundane will be quite befuddling to me. Furthermore, time moves quickly in the computer biz; what seems commonplace today will soon be obscure tomorrow. “Can you find the VGA adapter for the ADC cable, that short SCSI cable, and hockey-puck mouse while I move this CRT?” – Basil Bourque Sep 9 at 19:45

I cannot comment on popup asking for file size, but in Messages settings, Low image quality mode can be turned on. See last option in Settings -> messages It will be set for all images.

  • How to set this low quality image mode? – Basil Bourque Sep 6 at 20:22
  • Last option in Settings -> messages – ankii Sep 6 at 21:08

You can open the file with Preview and change the size of the file before you send it via message. From the Photo app you can export the photo as a jpeg say and then open it in Preview. Under the Annotate menu in Preview, you can save the size of the file. Once you decreased the size, you can then save it and send it using iMessage.


Are you using the built-in (it's typically on by default, at least it has been through most recent iterations of iOS, I'm assuming that it probably still is today) Photos app integration with iCloud? The one where it uses your iCloud storage space to back up all your photos automatically, with the choice of whether or not you want to use a feature called "My Photo Stream"...if you use this, then by default most of the time your photos should actually already be a compressed version that is of less quality versus the original image file. If you select the photo(s) from within the "Photos" app and use the share extension (that little square with the arrow pointing upwards out of the top, on the bottom bar of the screen) to copy/paste them into the body of your outbound e-Mails, or drag-and-drop them, it should send out the ones that your phone is automatically optimizing and not the full-sized ones.

Alternatively, you can try this app (it's totally free and there's no annoying premium things to pay for unlocking features or removing a watermark or anything like that, and no subscription nonsense), it's called Kompressor. I have used it for a while with good results, it's simple but it works. I choose to use it because it seems that by default when selecting the images through the 'attach items' option within Mail, it sends a request to the iCloud servers to download the full-sized version of the photo to send it to your recipient. Here's the link to the app: https://apps.apple.com/us/app/kompressor-compress-images/id1011979611

Note: you can tell whether or not the image(s) you have in your photo albums are in fact currently existing in their original, full-size versions or if they are in an optimized smaller file by looking for the presence of the little cloud icon in the bottom corner of the image when going through them in the album gallery.

  • Hi and welcome! But I find a lot of inconsistencies, 1 messages is separated from photos unless iCloud link is shared(that too is remote). Photos aren't mixed. So is photo stream. 2 If optimised version is shared using some app, as fas as I can remember, it waits for full version to download. That's why I turned off the optimise in the first place. 3 Are you using this answer to promote this app which I dont know if you have an affiliation with. 4 Question didn't ask if file size can be determined with some app or not. – ankii Sep 6 at 19:53
  • 1) Thought this was in relation to mail, not Messages? – netluxe Sep 7 at 10:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .