I can't get to the welcome choose your country screen when installing Mojave virtualised via Parallels Desktop 10 on my Yosemite system (MBP Retina 2015).

I downloaded the 6GB Mojave '.app' file as per the OSX Daily webpage (http://osxdaily.com/2018/09/29/download-full-macos-mojave-installer/) via the installer from this website: http://dosdude1.com/mojave/

1st attempt (via .app file): Parallels didn't automatically find the OS file so I located manually. I got the message "unable to detect operating system". I clicked continue and selected OSX. When starting up I got a boot failed message. I figured perhaps Parallels doesn't recognise an OS via .app file and that I should convert it into an ISO file...

2nd attempt (via ISO file): I created an ISO file from the .app file. I did this via steps 1-7 (under the 'Creating the installation media image iso' sub-heading)in this link: https://www.reddit.com/r/hackintosh/comments/a9twye/mac_os_1014_mojave_vmware_15_diy_guide_no_3rd/

Again Parallels didn't automatically find the OS file so I located manually. I got the message "unable to detect operating system". I clicked continue and selected OSX. This time I got the apple logo and load-up bar screen. I then got the MacOS Utility screen. After selecting 'install macOS'  and clicking continue it took several minutes to get to the next page. Then I got to the screen where It says select your drive to install. I selected the Macintosh HD and clicked next but then I got the error message: "An internal error occurred while preflighting your volume for APFS conversion". I was reverted back to the MacOS Utility screen. So this time I did not click on 'Install MacOS' instead I selected 'Disk Utility' and clicked continue which quickly took me to the Disk Utility screen. I selected the Macintosh HD and went on the menu bar to select [Edit -> convert to APFS...]. I got the dialog box 'Converting Macintosh HD to APFS' saying the conversion was complete and the operation was successful.

So now I got past the select your drive to install screen. However, I couldn't complete the installation. Using this video as a reference (https://www.youtube.com/watch?v=QbLEtH4PnlQ): I couldn't get past the blue loading-bar screen (6:00) ie. could not reach the welcome screen (6:03). Basically after the blue loading-bar screen I get the initial apple logo screen and then goes back to the MacOS Utility screen.

I don't know if this is an issue with Parallels Desktop 10, the Mojave file I downloaded or something related to compatibility. I prefer not to update/upgrade Yosemite.

Would greatly appreciate any advice.

  • It's probably an issue with Parallels 10, which has never heard of Mojave. Parallels 13 was the first to support APFS. I can't say for sure, as I'm on 14, but that's my guess. en.wikipedia.org/wiki/Parallels_Desktop_for_Mac has some guidance on which OS for which version, but sometimes it's hard to tell whether they mean 'will run on n' or you can 'run n on this version' – Tetsujin Sep 6 '19 at 10:26
  • Thank you @Tetsujin! I had a similar train of thought but wondering if it can be anything else - which so far appears unlikely. – questioner56 Sep 6 '19 at 10:33
  • With Sierra you could mark a flag in the installer to not convert to APFS; that's gone in Mojave. I'd guess [& it's only a guess] that will be the stumbling block ultimately. If it were me, I'd go to El Cap & Parallels 13. El Cap finished the work Yosemite started & is very stable as a point to 'leave it'. – Tetsujin Sep 6 '19 at 10:34
  • @Tetsujin is correct. fyi: You need 14 or greater. Parallels have a free trial. parallels.com/products/desktop – historystamp Sep 6 '19 at 21:48
  • When a new version of macOS comes out you need to upgrade to a new version of Parallels. – historystamp Sep 6 '19 at 21:49

Here are the visualizers that I know about.

Parallels: Full version http://www.parallels.com/en/products/desktop/ fyi: Free version of Parallels for individual use: https://itunes.apple.com/us/app/parallels-desktop-lite/id1085114709?mt=12 Free version, if still available, will only work with the most current version of macOS.

VMware Fusion With VMware Fusion, run the most demanding Mac and Windows applications side-by-side at maximum speeds without rebooting http://www.vmware.com/products/fusion/

VirtualBox VirtualBox is free, but you get what you pay for. Works fine for non-macOS operating systems. Nightmare to get to work for macOS. Basically, you need to match a version of VirtualBox with a version of macOS that will work. "VirtualBox is a general-purpose full virtualizer for x86 hardware. " Runs Windows on Mac OS. http://www.virtualbox.org/

| improve this answer | |
  • Thank you for reminding me about VirtualBox. I tried installing via ISO but came across a similiar scenario to Parallels 10 - after the first part of installation finished it restarted back to the MacOS Utility screen. HOWEVER, I stumbled on github.com/geerlingguy/macos-virtualbox-vm and youtube.com/watch?v=L2MvsbAt4TA and used the command-line from github and the '.vmdk' file linked in the youtube description. I managed to install Mojave! I'm still getting to grips with the configurations - so far haven't been able to access Host files from within the Guest OS. – questioner56 Sep 14 '19 at 10:24
  • You did super well. I may well have to give it a try. You could try file sharing on the macOS's. I've had better luck with NFS and NFS Manager. Get the NFS Manager app to set up. It's free. – historystamp Sep 14 '19 at 21:00
  • Historystamp, thank you for that tip. Although I can install NFS Manager on my Mojave guest (VM) I need to install it on my Yosemite host to share my host files to the VM - perhaps I should post a new question here about sharing folders from Yosemite host to Mojave guest via Virtualbox + NFS Manager)? The current NFS Manager version isn't compatible with Yosemite and the previous version (3.92) didn't work (bresink.com/osx/LegacyProducts.html) - double-clicking on the dmg file didn't load/mount it. – questioner56 Sep 15 '19 at 19:54
  • Historystamp, I did however manage to install Virtualbox Guest Additions via instructions on stackoverflow.com/questions/41691803/… with thanks to @Codeguard. I was expecting my shared folders to automatically show up somehow and that's where I'm stuck at the moment. – questioner56 Sep 15 '19 at 19:58
  • I did have a look at @klanomath's (that guy's awesome by the way) post on apple.stackexchange.com/questions/238836/… but I'm still not very clear on how to share folders in my situation. – questioner56 Sep 15 '19 at 19:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .