4

I have an Exchange account, that only works behind a corporate VPN on my personal laptop.

As soon as I'm disconnected from the VPN this appears

enter image description here

If I click close, it just keeps on popping up.

I just want it to stop pestering me when I'm not connected to the VPN.

1
  • Ultimately I just gave up on this and used Outlook.
    – Rol
    Feb 17 '20 at 16:44
4

Outlook is (for comparison purposes) a glorified IMAP client. EG it keeps everything on the server and Outlook is just viewing and changing data on the server.

So what you need to do is to tell Outlook to stop looking on the server for changes, which it does every few seconds.

Fortunately there has been an option in Outlook for a long time to allow you to do this.

  1. With Outlook active click on the Outlook menu
  2. Select "Work Offline"
  3. Enjoy your notification free existence

When you reconnect to your VPN you just have to go back to that same menu and select Work Online. With no dipping into network or notification settings, easy peasy.

2
  • I don't have outlook installed. This is a system level thing.
    – Rol
    Sep 9 '19 at 13:25
  • I use the Apple Mail app and tried Mailbox->Take all accounts offline but sadly it did not work. I think Rollo is right, this is nothing to do with Outlook.
    – Timmmm
    Jan 16 '20 at 20:13
0

Taking accounts offline in Exchange or Mail does not work. And there's no way to block notifications from the system in System Preferences -> Notifications. However turning on Do Not Disturb mode probably works.

Finding Do Not Disturb mode is the hard part! Apple have done an absolutely shit job of UI design here. Open the notification centre (top right corner of screen). Now you might thing this shows the top of the notifications, and you can only scroll down, as is the normal way things are done everywhere. But in this case you actually scroll up and then you'll see Do Not Disturb.

0

DND is a temporary remedy.

Another way is to temporarily uncheck all the services you use with the account in System Pref -> Internet accounts, select account and uncheck all in "Use with"

2
  • You can't because System Pref -> Notifications only lists apps that generate notifications. This notification is generated by the system - not by any app.
    – Timmmm
    Jan 16 '20 at 20:24
  • That's correct, fixed it.
    – anki
    Jan 16 '20 at 21:36
0

Deleting the exchange account and then adding it back worked for me. But this takes a while to re-download all the emails :(.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .