I have installed macOS Catalina Beta 7 on my MacBook Pro Late 2013. After installing, my Mac prompted me to Restart. While installing the update I noticed that the Apple Logo with the progress bar disappeared. Shortly after, the screen went black and the Macbook froze. I tried a hard reset, but it keeps booting to the "question mark" folder. I tried several boot up methods, clearing NVRAM, starting in safe mode etc, but the Mac simply ignores my keyboard inputs while starting up. My guess is that the Firmware / EFI got corrupt because I can't use any of the key combinations. I can only boot to the question mark folder.

Does anyone have any recommendations or ideas? Thanks in advance and sorry for my bad English :) !


5 Answers 5


I had the same experience with my MacBookAir. Turns out Catalina killed the firmware and the only solution according to the Genius Bar is to replace the motherboard. That is around 500 Bucks in my case.

  • 1
    The same thing happened to me. How can a software update result in a dead motherboard?
    – abel
    Commented Oct 12, 2019 at 18:29
  • OS install is when firmware updates happen. If the firmware update fails or is interrupted, the board itself needs service or a swap. It’s a very rare failure mode, but possible. Given 100,000 Macs, there will be some that need this surely.
    – bmike
    Commented Nov 29, 2019 at 21:27

Boot to Internet Recovery and erase / install is the best path when any update happens. In the vast, vast majority of cases you will be fine and only Macs with T2 chip would need an assist to re-flash the EFI. Yours is amenable to target mode boot and all the normal ways to reinstall the OS when it’s not bootable from the internal drive.

  1. Reset the SMC one time - https://support.apple.com/en-us/HT201295
  2. Internet Recovery would work for newer Macs - https://support.apple.com/en-us/HT201314 - your mac needs you to bring a bootable USB or drive to it or to connect in Target Disk Mode to another mac to image it / run the installer against your storage.
  • 1
    Thank you, but the problem is that my Macbook doesn't accept any key combinations at startup. Even with an external keyboard. It just ignores any input and boots straight to the folder with the question mark.
    – xxausstar
    Commented Sep 5, 2019 at 18:02
  • CMD+R, CMD+ALT+P+R, holding ALT,... nothing works
    – xxausstar
    Commented Sep 5, 2019 at 18:03
  • Have you reset the SMC one time? If so, it’s not the OS that’s broken. @xxausstar
    – bmike
    Commented Sep 5, 2019 at 18:19
  • Thank you for your help. I have tried resetting the SMC but the problem still persists. I have the feeling that I need a new logicboard :(
    – xxausstar
    Commented Sep 6, 2019 at 10:12
  • Agreed @xxausstar all signs point to hardware repair next
    – bmike
    Commented Sep 6, 2019 at 10:21

There are few possible scenarios.

1) Seems like your mac equivalent of bios is updated to not accept any previously supported boot methods. (Less likely).

2) The new boot loader is not allowing your “outdated” system for Catalina. (Thanks to Apple). If you were able to install previous beta versions of Catalina, this is also very less likely.

3)Your Boot partition is simply messed up during a restart or something.

My suggestion is to make a USB installer of the supported OS. You’d need a separate working system for that involving a free utility called DosDude.

Hopefully, you’d be able to install the previous supported stable OS (10.14.6) without formatting the HDD.


There is one hack (I'm not sure about MBP) but I experienced few years (some 20 years ago) on an unbranded desktop is to take out the battery (2032 battery cell which is found on motherboard) and place it again after few seconds. This is how we used to reset the motherboard.


1) Take out your HDD out of your MBP and connect it with as an external drive with some working computer. (TAKE THE BACKUP) and Format the HDD. Probably now, it won't have any issues with your computer.

2) If it still doesn't work, your BIOS firmware is corrupted. SMC firmware can be updated or downgraded. Follow these instructions.


You can find relative downloads on this page


Good Luck!

  • The weird thing is that everything worked fine till I installes the Beta 7 Update. Beta 5 worked flawless on my MBP and even my Mac Pro never had such problems. Normally I would create a new bootable USB installer, wipe the entire drive and reinstall Mojave, but booting from USB is somehow impossible as I can‘t select other boot-options on my MBP
    – xxausstar
    Commented Sep 6, 2019 at 10:16

Many Macs are being bricked. Apple is deleting solutions on the support page. The actual issue is this.

Apple removed 32 bit software in Catilina but kept a 32 bit program for entitlement management on the machine. This causes an efi chip (bios) corruption.

The offending app is located here: /System/Library/PrivateFrameworks/IMTranscoding.framework/XPCServices/IMTranscoderAgent.xpc/Contents/MacOS/IMTranscoderAgent


For T2 Macs. (look up T2 if you need to) if you see black screen yet hear power and chime there is a possible fix that has worked.

If you can get into single user mode (command + S when booting) or Internet recovery mode then use terminal then you could do these commands:

    dsenable root (enter password)

    /sbin/mount -uw /

    rm -rf /System/Library/PrivateFrameworks/IMTranscoding.framework/XPCServices/IMTranscoderAgent.xpc/Contents/MacOS/IMTranscoderAgent    

    dsenableroot disable

Since you don't have T2 Chip Macbook. There is a way to Reflash your bios with a Raspberri pi 3 and above.

Here is a video and post that can help:



  • Are you sure that the commands disenable root and disenableroot disable don't contain typos. In the past it has been dsenable and dsenable -d. The ds means Directory Services and is no way related to the latin prefix dis- (not, un- etc.).
    – klanomath
    Commented Nov 29, 2019 at 22:11
  • I think you may be correct!! Commented Dec 4, 2019 at 16:54

I had to fix two similar-vintage machines last year after their owners (who were both employed as coders at the same company) installed the Mojave developer betas; one was a 2013 13in, the other a 2012 15in rMBP and whilst you could press the button and they'd chime and glow, everything else was dead-dead.

Turned out the SSD-sticks had died (from over-use, old age or just entropy, we don't know), causing a short across the PCIe bridge that basically made the main logicboard data-mute. Fit some new Apple-branded Sandisks and they were all happy again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .