0

so I do have a problem. I create a backup partition, by mistake via Time Machine on my disk. I wanted to deleted 'cause it was above half of my memory. I couldn't, so I type some commands I found on internet, and now I don't have that partition. But I don't see any free space in Disk Utility. DiskUtility

Partition

I'm Pole so that's why language is polish. Anyway problem is that my disk is 500 GB, but I can see only 200GB claim, by "MacOSX". How can I add those almost 300GB space to "MacOSX" partition? I tried using Stellar:StellarPartitionManager

So I know it's possible, but i don't have money on full version of the program. So I ask You for help. How can I do it for free?

3
1

Have you try these steps to fix your issue:

$ diskutil list

It will list your physical drive detail. Note the drive name for unallocated space.

sudo diskutil eraseVolume "Free Space" %noformat% /dev/disk0s3

Assuming your volume is named disk0s3

Next, resize your APFS Container

diskutil apfs resizeContainer disk0s2 0

With value zero at the end, diskutil will automatically claim all available free space.

It should be fine and then you can re-setup macOS from Recovery mode.

7
  • I'm using Sierra, when I try to use it on my disk "MacOSX" it says "The target disk is in use by Core Storage as a Physical Volume; use diskutil coreStorage verbs". After using with coreStorage "diskutil: did not recognize coreStorage verb "eraseVolume"; type "diskutil coreStorage" for a list "
    – Nilille
    Sep 4 '19 at 16:44
  • @Nilille: Check this then apple.stackexchange.com/questions/154964/…
    – Udhy
    Sep 5 '19 at 9:54
  • when I type diskutil cs list, I get this "No CoreStorage logical volume groups found" I've tried doing this in recovery mode, as the tutorial says. My diskutil list looks like this: imgur.com/a/CFHy5JL . Another question should I expand disk0s2?
    – Nilille
    Sep 5 '19 at 14:36
  • Do you have any solution for that? Please?
    – Nilille
    Sep 8 '19 at 15:19
  • Share me your screenshot of diskutil with the detail view. I will try my best to help you. Which macOS version do you have in your system?
    – Udhy
    Sep 9 '19 at 8:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .