diskutil list

I basically tried to partition my 500GB hard drive to 350GB/150 GB ratio to install windows 10. However since the Bootcamp assistant could not download the windows support files it had to roll back. However, it’s been an hour since the process started and so I quit the BCA. I’ve uploaded a picture of the list of diskutil list and I have no idea what’s going on.

I’d highly appreciate it if one of you experts can show me how I can merge them back into Macintosh HD as a single 500GB volume.

Thanks in advance !

3 Answers 3


Basically, your question is a duplicate, which has be asked many times before. For example, see the question: The startup disk cannot be partitioned or restored to a single partition. Windows 10 and Mojave

I repeated my answer below. The answer was edited to more closely fit your question.

This is a very common question. Again, here is the commands you need to enter in a Terminal application window.

sudo diskutil eraseVolume free none disk0s5
sudo diskutil eraseVolume free none disk0s4
sudo diskutil eraseVolume free none disk0s3
sudo diskutil apfs resizeContainer disk0s2 0

These commands will have removed the Windows partitions and expanded the macOS partition to recover the free space. However, there may still be Windows boot files stored in the hidden EFI partition (disk0s1). These files can be removed by entering the commands given below.

sudo diskutil mount disk0s1
cd /Volumes/EFI/EFI
rm -r Boot
rm -r Microsoft
cd ~
diskutil unmount disk0s1

I usually use the Disk Utility tool to do this, because it shows the process quite clearly. It should be located in /Applications/Utilities/Disk Utility.

You might need to erase and/or reformat the partition before you can actually merge the partition. It's been a while since I've done this.

This article has a nice overview of all the necessary steps: https://www.imore.com/how-remove-hard-drive-partition-your-mac.

If this fails while you are running Mac OS, you can try starting it in recovery mode. Recovery mode has the same disk utility, but sometimes things fail when you are running Mac OS while trying to partition. You can start recovery mode by holding command+R while starting your mac.

  • Thanks for your reply Anton, I’ve actually tried going through the disk utility and erasing the partition but it won’t let me. It brings up a window with the text “Erasing [name] will delete all data store on it and can not be undone. Provide a name and format and click erase to proceed”. I’ve followed through that procedure multiple times and all that happens is that the volume name and format changed to something else. Sep 3, 2019 at 10:17

As far as I remember, you have to delete the partition with Bootcamp first before you can add it to the rest with DiskUtility.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .