8

enter image description hereSafari prompts "this web page is using too much battery" and restarts the web pages. Most of these pages are gmail, youtube, etc.

How to turn this feature off on macOS 10.13.6?

EDIT1: Memory - 8 GB 2133 MHz LPDDR3. Processor - 3.1 GHz Intel Core i5

EDIT2: While opening YouTube, it always says "the page was reloaded due to some error"

EDIT3: Just one extension - Grammarly

EDIT4: Another problem with YouTube (see image) (private window does not open YouTube at all) (I was currently at 3% battery at that time)

  • I don’t see that message at all for a month or more. What os are you running and have you looked at a JavaScript blocker? – bmike Sep 2 at 21:59
  • macOS 10.13.6. I am under the understanding that it is a Safari feature. – Harshal Parekh Sep 2 at 23:20
  • 1
    @n1000 16 GB must be really helpful in this case though. Lowers the percentage occupancy by a tab in total RAM. I am on 10.14.5. However, Safari doesn't restart the page though. Only a warning. It would be a disaster for unsaved work. – ankii Sep 8 at 18:04
  • 1
    I can at least recommend clearing cache if you can tolerate loosing some log-ins. Also, try and check the behaviour in Safe mode of safari itself (hold down shift key and click on Safari icon in dock. ) apple.stackexchange.com/questions/12049/… How many extensions do you have? – ankii Sep 9 at 20:29
  • 2
    "too much battery" implies processor usage is high. I suggest you run activity monitor to verify that Safari is using a lot of the processors. As a test, turn off grammarly. – historystamp Sep 10 at 1:07
2
+50

You should look for the problem that is causing this trouble rather than hacking the Safari to stop showing you notifications. If it's upto to kill the process, preventing notifications will not stop it.

Here are few troubleshooting tips.

1) Check your disk space where your OS is installed. Free if needed (Swap memory reason)

2) Check your HDD & Battery health. You can get few freeware utilities.

3) Check temperature of your system. It often crash apps or even restarts the devices.

4) Clear the browser cache folder from base. See this Post for details.

5) Reset SMC

Press Shift + Control + Option + Power button at the same time. 
Release all keys and the power button at the same time.

6) Reset NVRAM

Shut down your Mac.
Press the power button.
Before the grey screen appears, press the Command, Option, P, and R keys at the same time.
Hold the keys until your computer restarts and you hear the startup sound a second time. ...
Release the keys.

7) Check for Safari and iTunes Updates.

If none of the above works and your hardware has no issues, than probably it's time to fresh install (upgrade) your OS.

  • Could you also add extension-disable troubleshoot too? Browser seems to be at fault. – ankii Sep 23 at 10:31
-4

I have heard about this issue recently a lot. How much do you need to sync Safari on your icloud?

I would suggest you turn off Safari to sync with your icloud. This has helped in iOS as Safari takes a lot of battery.

Go to Internet Accounts from System Preferences, and under your icloud, uncheck Safari.

I am sharing this as it worked on iOS which reduce a lot of battery consumption after unchecking it. Would be happy to know whether it will help on macOS or not. Let me know how it goes.

  • 4
    That will not solve the problem. Syncing between devices is one of the only reasons I still use Safari – Matthew Barclay Sep 9 at 13:15
  • 2
    Also, your "solution" is for iOS, not macOS – Matthew Barclay Sep 9 at 13:26
  • 1
    I agree with @MatthewBarclay – Harshal Parekh Sep 9 at 17:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .