My MacBook Air stopped being able to connect to the wireless network at a coffee shop I frequent. It's an open network, but requires a clickthrough on a gateway page to complete the connection to the internet.

My iPhone accesses the click through page fine and connects to the network, but my Air cannot load the page, the autoconnect pop-up will load forever, and I get a timeout when going through the browser.

Is it possible there are some stored settings for this network that I need to clear before trying to connect again? I've tried removing the network from my list of preferred networks, looking for any entries in my keychain, and accessing the network through my guest account. Any suggestions are appreciated!

Lion 10.7.2

  • Which MacBook Air, and which iPhone?
    – bneely
    Jan 14, 2012 at 20:37
  • Did you resolve this question?
    – Blaszard
    Aug 30, 2017 at 17:05

1 Answer 1


Two things you could check:

  1. Do you have a Proxy set?

  2. Do you use some VPN?

Maybe an adblocker could also be in your way.

  • proxies are all unset, I do use tunnelblick for work but the application was not on and the wifi works fine everywhere else. I've tried clean copies of chrome and safari.
    – Adam Dukes
    Jan 16, 2012 at 17:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .