1

I recently upgraded from OS 10.13 to OS 10.14 on a new 2019 Mac 21.5" with 16 GB RAM

When I install my MFC-L2700DW Printer I get a Print Error message when trying to print. I have tried to print PDF and Word with no luck. Running on the same network is my old OS 10.13 2011 21.5" mac which has run the brother printer for the last few years without issue and continues to print without issue. The print error log in OS 10.14 is displaying the following messages

[cups-driverd] Unable to open driver directory \"/usr/libexec/cups/driver\": No such file or directory
[Client 27] Returning IPP client-error-document-format-not-supported for Send-Document (ipp://localhost:631/printers/Brother_MFC_L2700DW_series) from localhost.

Things I've tried

  • I have installed the printer using both the CUPS driver and using AirPrint with no success. I have removed the printer and reset the print system with no luck.
  • I have tried in safe mode with the same print error message.
  • I have tried a factory reset on the printer.

The Brother print driver is in the folder /Library/Printers/PPDs/Contents/Resources/Brother_MFC-L2700DW_series _CUPS.gz.

Any assistance would be great. Thanks

  • macOS doesn't normally need 3rd party drivers. Most printers these days are driverless anyway. Apple has a list of supported printers & that machine is on it. The list is no longer maintained because of the newer driverless structures - support.apple.com/HT201465 – Tetsujin Aug 30 at 9:05
  • Yes I believe that is the case, nevertheless when I remove all print drivers from the machine it will reinstall a heap of Brother Cups print drivers them when I add after removing it and resetting the print system and then adding the printer again. I had seen the list that you sent on. the link. – Daryl Hodson Aug 30 at 9:09
  • I've never used a printer that insisted on cups in a very long time, sorry. My /usr/libexec/cups/driver folder is there but empty – Tetsujin Aug 30 at 9:11
  • Thanks for your help. May be that new printer is required. – Daryl Hodson Aug 30 at 9:29
  • kb.lesolson.com/InstantKB2016/KnowledgebaseArticle50248.aspx Even though this is for an older system, I copied the files out of the cups/backend Time Machine Backup prior to updating to Mojave. I then added the brother printer as a shared printer from the machine running High Sierra and it now prints. – Daryl Hodson Aug 30 at 12:43

You must log in to answer this question.

Browse other questions tagged .