3

I want to use Terminal in full screen on one monitor while having the desktop accessable on the other. pressing the green button in terminal fills screen 1 with terminal (good), but the other is blank (bad). It would be nice if the other were the desktop or another app.

To sum it up, this is how is is for me now:

Screen 1 | Screen 2
-------------------
Terminal |  Blank

When Terminal is fullscreen, the other monitor becomes blank i.e. nothing on it.

Screen 1 | Screen 2
-------------------
 Blank   | Terminal

The same rule applies regardless of what monitor Terminal is on.

This happens to any and all apps, not just Terminal.

I want it to look like this:

Screen 1 | Screen 2
-------------------
Terminal | Desktop

or:

Screen 1 | Screen 2
-------------------
Desktop  | Terminal

or another example:

Screen 1 | Screen 2
-------------------
 Safari  |  Pages

Ideas?

High Sierra 10.13.6

  • Could you please send a screenshot because your question is not very clear to me. Thanks. – Dakta Moriamé Aug 29 at 21:32
  • System preferences > displays. One should be the desktop, the one with the bar indicating the menu. When you know which is desktop, then open the desired app on the other. Unless I’m misunderstanding your question. – bjbk Aug 29 at 23:47
  • @DaktaMoriamé A screenshot is difficult with two monitors and will not convey my message very well. I have edited my question to re-explain. Hope this helps – leetbacoon Aug 30 at 2:52
  • @bjbk Thanks but that is different. I have edited my question to re-explain. Hope this helps – leetbacoon Aug 30 at 2:53
2

Ensure that "Displays have separate Spaces" is checked:

System Preferences > Mission Control > Displays have separate Spaces

This should fix the blank screen issue.

Misson Control System Preferences

  • 1
    Works perfect, thanks! – leetbacoon Aug 30 at 3:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .