0

This is actually an issue I've had for a long while now, I've seen it to some extent or other on several Macs I've owned over the years, but on the 2014 Mac Mini it's really bad.

The problem is that when I put the computer to sleep, when it wakes the bluetooth radio is (almost) always disabled. The Bluetooth icon in the menu bar is greyed out. I can right-click the icon and select "Enable bluetooth" from the menu to get it back up and running, so it seems like the hardware itself is fine, and that the drivers are working, but it almost always seems to be off by default after a sleep. Does anyone know why this may be, or what to do about it? Like I said, it's not a critical issue, but it's really annoying.

Mac Mini (2014), OSX High Sierra.

  • Under System Settings is Wake for network access enabled? Try enabling it if not. Also check settings under Bluetooh -> Advanced button and enable "allow bluetooth devices to wake this computer" – Prado Aug 29 at 19:43
  • @Prado No, those are both disabled because I don't want network or bluetooth activity waking the computer when it's asleep! – GordonM Aug 30 at 6:51
  • Just for testing purposes, my intention was for you temporary test it with those parameter, so I can understand better and depending on your feedback I will dig deeper so we can isolate the cause and make it work the way you want. It's not a final setting, like "do it", it's for my understanding of the situation and debugging based on your feedback, to continue helping you – Prado Aug 30 at 16:19
  • @Prado I've just tried it quickly with wake on bluetooth enabled and disabled. In both cases bluetooth was active when the machine woke up, but that was only for a few seconds. The problem seems to manifest after several hours of being asleep. I don't know if this has anything to do with it but it's when the machine has gone into a "deep" sleep (completely powered off and requires the power button to be pressed to wake from hibernation) that the problem usually manifests. – GordonM Aug 30 at 19:57
  • Thanks for the info, I will try to figure it out something related to that scenario – Prado Aug 30 at 20:00

You must log in to answer this question.

Browse other questions tagged .