1

When I'm making a phone call with my iPhone, under the audio button typically I can toggle between phone and speakerphone. But recently a third option appeared, which claims to route the call to my Mac. I never want to use this option, and I want to be able to just tap to turn the speakerphone off and on. Is there any way to turn off the Mac connection so that it won't appear?

I have disabled Allow Calls on Other Devices on my iPhone and that didn't have any effect.

Note: related Apple Community question.

Photo of the audio button Photo of the audio options list Allow Calls on Other Devices is disabled

3

Try allowing all devices and then disabling Mac specifically in the "Calls on other devices" settings you posted.

Open FaceTime-> Preferences on Mac and uncheck receive calls from iPhone checkbox.

On the extreme, if you don't use continuity feature, (didn't see it in the question), could you turn Handoff off altogether in iPhone and/or Mac? It is in Settings -> General-> Handoff on both devices. Either of the devices could be at fault. So check all combinations.

| improve this answer | |
  • I'm not sure what step solved it for me, but some combination of Turning off just the Mac under Call on other Devices and Turning off Handoff, which I never loved, and THEN doing a hard reboot on the iPhone finally cleaned out the Mac as an audio device. Thanks All! – Allen J May 21 at 18:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .