3

For a couple of days, I have been getting this issue with my iPhone. For some Apps, It says

This discounted price is only available to customers who own a previous version of this item. To purchase this item at full price, click buy.

while trying to update it. How do you make the iOS device update the apps.

Additional Information about my phone:
iPhone 6+
iOS version 12.4.1
App Store Australia

App store screenshot

  • Better contact the app developer directly, I suppose this is a change on the app commercial model – Prado Aug 28 at 18:40
  • 1
    Try signing in and out back – ankii Aug 29 at 1:09
  • @Prado I had 30+ apps that were stuck into this situation. It's not about App. It's about the issue of the phone. – Tulon Aug 29 at 21:27
  • @ankiiiiiii I have tried that as a first step. But not worked. Thanks for the suggestion by the way. – Tulon Aug 29 at 21:28
2

I have this same problem on an iPad. If I uninstall the app I'm able to install the new version - but like you there are 10 apps I have this same problem with.

My suspicion is that these apps were installed when the iPad was setup to use Apple Account "A". A number of weeks ago I switched the Apple Account of the device to be account "B". So I think the problem is that the app store is preventing an app, installed by "A", being upgraded (for free) by "B".

Is anyone able to confirm this hypothesis?

UPDATE: Yes, this was my problem. I used the old account within the App Store and I was able to update those 10 apps.

  • Thanks for your suggestion. – Tulon Aug 29 at 21:52
1

Finally, I overcome from this situation. All I need is to update my iOS. To me, it seems like it wasn't updated properly. Or it was stuck into "Insatall the Update" state. So I installed the update (From Settings > General > Software Update > Install). And now all pending updates are downloading.

Things I have tried but didn't work are as follows:

  • Sign Out from App Store and Sign In again. (From App Store > Profile (Top Profile Picture) > Sign Out)
  • Change Region and Reselect again. (From App Store > Profile (Top Profile Picture) > Your Name on top (It will move you into your Account) > Country/Region > Change Country or Region > Select)
  • Reset Network (Settings > General > Reset > Reset Network Settings)

If you are facing this problem, you may try these, but now work for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .