3

When I'm using arguments with quotes in the Terminal, the quote is first highlighted and then changes to a special character when certain characters are entered after it.

For example trying to type "u changes to ü.

How do I disable this?

I'm on OS X El Capitan, 10.11.6

3
  • Could you give a more complete example of this? I'm in Terminal and I can type a double-quote, then a lowercase u, and the umlaut does not appear. – IconDaemon Aug 28 '19 at 12:58
  • Well I can't really explain it any further. I must have changed a system setting somewhere that enables it but I have no idea how to change it back (I'm not a mac guy). – Jimmi Aug 28 '19 at 13:05
  • Hi Jimmi, welcome to Ask Different. Which keyboard is configured on your Mac? (You can find this information in Apple menu>System Preferences>Keyboard>Input Sources) – jaume Aug 28 '19 at 13:18
3

Go to system prefs/keyboard/input sources and get rid of the layout called US International PC. Use US or ABC instead.

1
  • That did the trick, thanks! 😁 – Jimmi Aug 28 '19 at 16:44
-2

If you are using iTerm2, then select Esc+ for the Left Option Key in Preferences > Profile > Keys. Then you can use Option-b for the previous word and Option-f for the next word.

enter image description here

1
  • This answer doesn't seem to have anything at all to do with the question. Did you intend to post it somewhere else? – Tom Gewecke Jan 15 at 12:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .