0

I very often take screen shots, and have my system configured to save them directly to the desktop, without the intermediate processes.

This question has been asked a lot. For example, see the following:

Capturing screenshots on macOS Sierra is very slow Screenshot taking a very long time to appear on desktop

However, none of the situations and solutions discussed there are applicable.

  1. The questions above talk about 5-6 seconds to save. On my system it takes 15-20 seconds. This is a 2017 iMac; not a slow machine. The delay is very annoying as when one saves to the desktop one usually needs the resulting file immediately, so I have to wait for it to appear.

  2. A lot of the discussion talks about Google Backup and Sync. I have never used these.

  3. Some of the discussion talks about turning off anti-virus. As I test, I turned off Bitdefender. It made no difference.

Any other ideas?

EDIT: as soon as I saved this question, it occurred to me from the solutions based on disabling certain services, that maybe something like that was involved. On a hunch, I decided to disable Spotlight indexing of the Desktop folder, by adding it to the Privacy section. After all, I don't really need Spotlight for the relatively small number of objects I allow on my Desktop.

Interestingly, this worked! Screen shots now save in about 2 seconds.

Putting this as an "edit" rather than answering my own question, because this is a workaround, and there might be a better solution.

  • 1
    The "Remember Last Selection" was already checked for me, as well as "Show Floating Thumbnail" unchecked. For me the solution was to disable Spotlight for the desktop. – Jeffrey Simon Aug 29 at 13:58
  • Could you write an answer for the same please ? – ankii Nov 12 at 18:07
  • It's my question so it wants me to comment. But in any case, it is not a good solution. It seems that when you make changes to various settings, it may or may not affect the long delay time. But then later on the long delay returns. It is like randomly changing settings affects the delay, but only for a while. Because the delay had returned, I checked and found that Desktop had been removed from Spotlight Privacy. So I added it back, and the delay is now removed. But it will remain to be seen if this is just temporary or a real fix. – Jeffrey Simon Nov 13 at 21:05
  • you can find an "Answer your question" button at the bottom. If you add an answer, others wouldn't have to look into comments(which are temporary). we can link answers more easily. – ankii Nov 13 at 21:07
1

What worked for me on macOS Mojave to have screenshots saved to my Desktop instantaneously, was to uncheck Show Floating Thumbnail from the Options menu when pressing ⇧⌘5.

This change carried over to the other screenshot keyboard shortcuts too.

enter image description here

Note that I still allow Spotlight to index my Desktop too.

  • That suggestion is in the article I cited. But it is already unchecked for me and thus is not a factor for me, but clearly is a first thing to try since it has helped so many. For me the solution is to add the Desktop to Spotlight Privacy section. – Jeffrey Simon Aug 29 at 13:54
  • @Jeffrey Simon, I didn't read the article, only stated what worked for me. You should have mentioned your other settings in the OP! – user3439894 Aug 29 at 13:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .