3

Here is my very sad story. I have a Macbook pro 13" retina early 2015 (MB 12,1). My bootrom version is MBP121.0167.B07 and according to this ( https://docs.google.com/spreadsheets/d/1qGRVF1aRokQgm_LuTsFUN2Knrh0Sd3Gp0ziC_VIWqoM/htmlview ) table I'm running a veeery old firmware, updated to yosemite.

I found this problem while I tried to upgrade to mojave (I'm runnig Sierra right now). Error while verifying the firmware. After many tries and repairs to the disk, I found the problem: my firmware.

So i tried many thing to update it. Install mojave on a external drive didn't help (same firmware error). I tried to boot with mojave using carbon clone (I cloned the hard drive from my girlfriend's macbook updated to mojave). I also tried to do a update while in mojave, but nothing.

I tried a fresh install of sierra, but no firmware updates. I tried to use El Capitan from a external drive, still nothing.

I tried some tool to install the firmware right from highsierra installer, nothing.

I tried to install it manually with bless command. The output was good, it sets the nvram to install the update after the reboot but nothing.

What should I do? Change the logic-board seems expensive and stupid if the problem is just a upgrade.

Thanks everyone.

  • UPDATE for everyone: I tried the internet recovery and It just let me to install a fresh copy of Yosemite. I can't access to my internal drive from yosemite and I don't know why, so I installed Yosemite on a external drive but no EFI update either "EFI firmware version check: [-] ATTENTION - You are running an unexpected firmware version given the model of your system (MacBookPro12,1) and OS build you have installed (14F2511). Your firmware is MBP121.0167.B07, the firmware we expected to see is MBP121.0167.B14." I can't update to el capitan and Sierra update doesn't change the firmware. – Narag Aug 31 '19 at 11:56
  • The firmware update you need for APFS and Mojave comes with the 10.12.6 update. Install 10.12, using a version prior to 10.12.6 and apply the combo update for 10.12.6. During the upgrade process your firmware will get updated. Unfortunately I don't know where you can get an Installer old enough for the suggested process. So if you found a tool to extract the firmware updates of update packages, try to extract from the 10.12.6 combo update package. – Adrian Zaugg Nov 14 '19 at 23:02
2

Your question does miss some key details, so this answer makes the following assumptions:

  • You've correctly identified your current Boot ROM version
  • Your MBP still has the original Apple SSD installed
  • You've already tried (directly or indirectly) resetting the NVRAM
  • You've never installed macOS High Sierra on your MacBook Pro

Essentially, some years back Apple started automatically including firmware updates (if/when required) within macOS updates/upgrades. And, with the move to the APFS file system, firmware updates were required on pre-existing Macs with SSD drives to support macOS High Sierra (and above) as they required APFS to be installed. So, cutting a long story short, you're most likely missing this firmware update.

Since you've already gone through quite a bit of frustration, your best bet is to go through a total reinstall process. My recommendation would be to do as follows:

  1. Make a full backup of your data using Time Machine (or your preferred backup solution)
  2. Shut down your MBP
  3. Switch on your MBP and immediately press and hold the OptionCommand ⌘R keys *
  4. Let go of the keys once you see either the Apple logo, a spinning globe or a firmware password prompt
  5. When the macOS Utilities window appears select the Disk Utility option
  6. Proceed to erase your internal drive
  7. Quit Disk Utility
  8. The macOS Utilities window should reappear
  9. Now select the Reinstall macOS option
  10. Proceed to install macOS
  11. Once the installation is complete, migrate your data across

* This specific key combination will install the latest version of macOS compatible with your model Mac, which presently is macOS Mojave.

| improve this answer | |
  • my Boot rom version is MBP121.0167.B07, I have a original Apple SSD and I tried to reset NVRAM up to 5 times in a row. I can't install mac os high sierra on this machine due to firmware, so I'm stuck on sierra. I already tried some clean install from the recovery, the firmware is not updated too. – Narag Aug 28 '19 at 10:32
  • In other words, my assumptions are spot on. If you follow my answer the firmware should be updated when the macOS Mojave installer prepares your drive (which was previously erased at Step 6) for installation. That is, as part of the process, the installer should update the firmware and then reformat again your internal SSD before proceeding to install macOS Mojave. – Monomeeth Aug 28 '19 at 11:02
  • I can't install mojave because of the "an error occurred while verifying firmware" message error. I think my firmware is corrupted, because after the bless command, NVRAM are good and the system tries to install the firmware (the boot takes longer) but I assume the system can't verifying the signature of my current firmware (or, it's just corrupted and different from a original one). I'm wondering if is it possibile to manual flash a firmware via software, maybe with some live version of linux. – Narag Aug 28 '19 at 13:25
  • Just so I can be 100% sure of what's going on, did you follow all my steps? Or did you take some shortcuts? – Monomeeth Aug 28 '19 at 21:53
  • Also, I keep forgetting to ask you to clarify this statement: "I tried some tool to install the firmware right from highsierra installer". What tool did you try? – Monomeeth Aug 28 '19 at 22:37
0

You left out one important part - when an OS install sees it needs to update firmware, it can only be done from the internal drive during the full installation process ... and on your model, it has to be an Apple SSD-stick.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .