3

This question already has an answer here:

Something is wrong with my keyboard or Mac settings for key repeat rate and delay.

My Keyboard settings are as follows:

enter image description here

Yet when I hold down my keys one of two things happens. A) The character only appears once or B) I get foreign character options such as:

enter image description here

I tried the terminal commands from How to increase keyboard key repeat rate on OS X? to no avail.

I tried resetting the NVRAM to no avail.

I tried rebooting my Mac to no avail.

What does work is I can use the Keyboard Viewer and if I click on a character (such as ’S’) I do get sssssssssssssssss, but if I press the physical S key the Keyboard Viewer shows the keypress but I only get the same foreign character options again.

So, is this a physical fault on my keyboard or what??

marked as duplicate by Tetsujin, fsb, nohillside Aug 27 at 14:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Very similar yes, but not a duplicate b/c they only had a problem with a single key 'I' but I had the problem with all keys. – user343533 Aug 27 at 12:24
  • All Mac's have worked this way by default since 10.7 was released 8 years ago. – Tom Gewecke Aug 27 at 12:26
  • Sure - it was one of many I found where the 'fix' was the ApplePressAndHoldEnabled defaults setting. I tagged a comment for Monomeeth [who is one of the moderators here] to have a look at some of them & see if we can cross-link in some useful way. – Tetsujin Aug 27 at 12:26
  • @TomGewecke Not sure what 10.7 is, but this is my first Mac. Have only had it a few months since brand new and loving it sooooooooooooooo far. Oh look, my 'O' key repeats now! – user343533 Aug 27 at 12:32
  • 1
    Cross-linking & even closing all against one clear 'master issue' makes it better for future googlers - they find any one of these, they find them all & can use the one most fitting to their own situation. There's no loss of reputation [or indeed honour ;) if any question is closed as a dupe, it just ties things together more neatly, long-term. – Tetsujin Aug 27 at 14:16
3

No, your keyboard is almost certainly not faulty. In fact, if you hold down some keys, such as the full stop . or space keys you should see that they repeat just fine.

Assuming that’s the case, you have one of two options:

  1. keep your Mac as it currently is and use the Keyboard Viewer with your mouse if/when you need to repeat other characters, or
  2. totally change the default behaviour so that you don’t get the popup with special characters.

If you opt for the 2nd option, then you’ll need to do the following:

  1. Run the following command in terminal:

defaults write -g ApplePressAndHoldEnabled -bool false

  1. Restart your Mac

Now you’ll have your keys repeat the way you want.

Not the answer you're looking for? Browse other questions tagged .