2

Not sure when this started, but I can't seem to get any keyboard input in my serial terminal window. No issues however in binding the tty.usbserial interface to the terminal program and getting output from whatever device is connected. But once I start hitting the keyboard, nothing shows on the terminal window.

I have tried zTerm and CoolTerm as serial terminal programs and I'm on macOS Mojave 10.14. Oh and not to forget the built-in "screen" program. Tried several devices with a console port.

ls /dev/tty.* 
/dev/tty.usbserial-A700HCG8

What can I do to troubleshoot & hopefully fix this issue?

1 Answer 1

2

Usually this means that either:

(a) the target device is not sending back any response to your keystrokes

or

(b) your flow control settings are incorrect

or

(c) you have a defective cable.

If (b) is the case, you'll to make sure that the settings XON/XOFF, RTS/CTS and DTR/DSR are set correctly. You can just try flipping them manually, as nothing "bad" happens if you set them incorrectly (except not being able to send/receive data).

If (c) is the case, try with a different cable. It is possible to have a cable that only works in one direction due to a hardware problem.

1
  • Well, there you have it. It was (c), a defective cable with one directional flow data... thanks a lot for your detailed answer!
    – Beeelze
    Aug 26, 2019 at 11:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .