0

MacOS Mojave 10.14.6 Processor: 2.8 GHt Intel Core i7 Memory 16 GB

I want to partition my Disk because I want to try to install Linux-Ubuntu. For this I'm following this tutorial.

In Disk utility I clicked on the main volume > partition > partition but the following message appears:

This container has 915.81 GB used space.
Its minimum size is 1 TB.
This container cannot be split because the resulting containers would be too small.

And I cannot click on the + button to partition the disk

I then tried the following:

  • I then tried to make some space and deleted around 300+ GB of data and have now 439 GB (when I go to apple button (above left) > About this Mac > Storage). However, in Disk utility the amount of free memory didn't change and is still only around 85GB and it is still not possible to partition the disk.

  • I deleted 2/3 automatic time machine backups with

tmutil listlocalsnapshots /
tmutil deletelocalsnapshots ...
  • deactivated the automatic time machine backups with
sudo tmutil disable localsnapshot

What should I do?

EDIT

Here is the screenshot from diskutil where the problem is appearing:

enter image description here

1

is it an apfs vol? did u try to partition the volume without a specified format? please post more info !! off the top of my head i can think of a couple of things, mainly

diskutil eraseVolume /dev/diskXY (where X= the disk and 1 the volume within that disk) "Free Space" "%noformat%" <desired amount, %, or if you've already created a separate volume use the R option or 100% in order to erase the entire volume>

diskutil partitionDisk /dev/disk2 1 GPT "Free Space" "%noformat%" "100%" 
or format it as a FAT32 part and use that for linux(its been a while since i've done this myself; but i can find u some resources if u'd like...)

check the man pages, man diskutil

also what mac are u using?(make model and what not ... it might be handier to install refit/refind and use that as boot manager before installing ubuntu so that your mac will always boot up into a custom bootloader with a choice of operating systems).

if none of these are viable options or you'd rather not mess with the bootloader, why not just install vmware fusion, virtualbox and use ubuntu as a virtual machine (depending on what you'll be using it for, not too much resources need to be allocated; i'd start off with 2cpu and around 2048-4096mb of ram[this, of course, is dependent on what you're initial resources are...if u're running an old dual core processor and only have 4G of ddr3 ram, then the initial option with refind/dedicated partition might be the way to go.])

What will u be using ubuntu for?

Have you created a liveusb and booted into ubuntu already ?! Are you familiar with linux?!

  • Thanks for your answer @F M. I have the following: MacOS Mojave 10.14.6 Processor: 2.8 GHt Intel Core i7 Memory 16 GB. I added a picture of what appears on diskutils (i cannot click on the "+" button). You mean I should do everything from the terminal? The use of Ubuntu: no particular goal yet, I want to try a system which is open source and "closer to the hardware" – ecjb Aug 26 at 18:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .