1

I am trying to change the startup sound. When I checked the setting using:

sudo nvram -p

it returns a setting for SystemAudioVolume DB %ee

I entered:

    sudo nvram SystemAudioVolume=%00

When I check again using sudo nvram -p

both names show up in the list:

SystemAudioVolume DB .... %ee

SystemAudioVolume .... %00 (it took my setting but doesn't kill sound)

Should I be trying to set SystemAudioVolume DB instead?

If yes, is this the right way?

sudo nvram SystemAudioVolumeDB=%aa

(No space before DB.) Does anyone know the proper range for this? My computer is old but I don't want to break it.

0

Firstly, the sudo nvram SystemAudioVolume=%00 (or the same command with different values at end) never allowed users to actually change the startup chime sound. In earlier versions of Mac OS X it did allow users to change the volume, and therefore they could mute the startup chime, but this did not change the sound.

The closest thing to changing the sound is a hack that allowed users to mute the startup chime and then add another sound that occurred upon logging in to your user account - but of course this is not a startup sound, just a sound that plays when you log into your user account.

As for whether SystemAudioVolume has been replaced with SystemAudioVolumeDB, the answer is no. In fact, as you have seen from running sudo nvram -p, these two parameters have totally different values.

Summary

  • No, the Unix parameter SystemAudioVolume has not been replaced by SystemAudioVolume DB in El Capitan
  • The Unix parameter SystemAudioVolume has never been used to change the startup chime sound - only to change the volume level
  • The startup chime sound cannot be changed

Further reading

These related questions may interest you:

  • So sorry, I meant I want to change the startup sound volume, not the sound itself. You said the two parameters have totally different values — – Hawaii Dee Gee Aug 25 at 5:46
  • You said the two parameters have totally different values — SystemAudioVolume only appeared in the list after I set it. I later reset the default parameters with: sudo nvram -d SystemAudioVolume After doing this, I checked it again and the term SystemAudioVolume does not even appear in the list, only SystemAudioVolume DB shows up. This lead me to suppose it had been changed. I don't want to silence the sound, just make it soft. – Hawaii Dee Gee Aug 25 at 6:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .