![enter image description here

Stuck on the above screen for over 30 mins.

I’ve tried restarting and rebooting after shutting down - and I get the same result.

This is on a MacBook Pro running Mac OS Mojave.

update 1 - I’ve tried booting in recovery mode and running the first aid operation in disk utility. That was all fine. No change with login issue.

update 2 - I held the power button, restarted and held shift. The machine refuses to boot in safe mode. It goes straight to the normal login page every time, not the safe mode login page(there's no safe mode written in menu bar). I entered my password and had the same stuck bar issue.

update 3 - I have removed FileVault encryption by following this. This link explains how to remove a drive’s encryption from the terminal in recovery mode.

I have then run the disk repair utility on the now unencrypted drive. It’s says everything is good. This didn’t fix the issue. There is now no login screen. I’m stuck with the apple logo and the loading bar in the same place.

enter image description here

update 4- I have tried booting in verbose mode. It is unclear if there is any issue. There is no obvious error or repeated logging.

I have also tried single user mode and running fsck -fy as the answer below suggests. That didn’t fix the issue.

I have set to boot-args=“-x” to force safe mode. In what should be safe mode the boot still gets stuck on the above screen with loading bar.

  • 1
    support.apple.com/en-us/HT201262 Never had this, but try safe boot? It will disable a lot of things which will help isolate causes.
    – anki
    Commented Aug 24, 2019 at 18:39
  • 1
    @ankiiiiiii - not sure whether it’s related but it refuses to start in safe mode. When restarting or rebooting from shut down it goes straight to the page requesting login credentials. I’ve tried multiple holding shift combinations and even entering nvram boot-args=“-x” to the terminal from recovery mode
    – kindjacket
    Commented Aug 24, 2019 at 19:29
  • @ankiiiiiii how long do I press it to restart or shutdown? I press it once no hold then press shift to attempt to boot in safe mode. The apple logo flashes up briefly, no loading bar, then it goes directly to the login page.
    – kindjacket
    Commented Aug 24, 2019 at 19:43
  • 1
    @ankiiiiiii - ahh yes - I’ve tried that. From googling it should say safe mode in the top right hand corner when at the login part. I have tried logging in when doing the attempts at safe booting and I have the same loading bar issue.
    – kindjacket
    Commented Aug 24, 2019 at 20:15
  • 1
    @historystamp - yes. I’ve updated the post.
    – kindjacket
    Commented Aug 26, 2019 at 22:18

6 Answers 6


I have fixed the issue. It manifested after the installation of a driver with an unsigned .kext file. In this instance, it was from this driver (Roland DJ-202 DRIVER VER.1.0.3).

At the time I didn't think this was causing the issue because this driver was installed and ran fine on a friend's MacBook Pro running on Mojave. The difference was that his machine is running 10.14.3 and mine is running 10.14.6. It seems that this driver does not work on macOS Mojave 10.14.6.

I discovered the issue after reading through this. After moving all the .kext files to an unsupported folder (see below) I was able to boot successfully boot the machine in safe mode and normal mode.

mount -rw /
cd /Volumes/Macintosh\ HD/Library/Extensions/
mkdir Unsupported
mv *.kext Unsupported

After reading through this I was able to identify the .kext files that are properly signed by Apple. They are the following

ACS6x.kext                CIJUSBLoad.kext
ATTOCelerityFC8.kext      CalDigitHDProDrv.kext
ATTOExpressSASHBA2.kext   HighPointIOP.kext
ATTOExpressSASRAID2.kext  HighPointRR.kext
ArcMSR.kext               PromiseSTEX.kext
BJUSBLoad.kext            SoftRAID.kext

I then identified the culprit file from the driver - RDUSB0205Dev.kext. I moved all the other .kext files back into the /Volumes/Macintosh\ HD/Library/Extensions/ folder.

The machine now boots fine, and everything is back to normal.

  • hey a sincere thank you for not abandoning this post after finding your solution. I just installed a Roland TD-17 driver on my Mac, rebooted and had this same issue. I was just about ready to wipe my machine before I found this post. So many thanks for saving me countless hours! Commented May 3, 2020 at 1:23
  • I had a similar problem after installing a Wacom driver. Thanks so much (!) for pointing me to /Volumes/Macintosh\ HD/Library/Extensions/. Removing the Wacom file there made the mac boot up again. Commented Dec 12, 2020 at 9:08
  • Out of curiosity, how did you all even get to a command line? When I boot I into safe mode, I can't get past login...
    – James P
    Commented Jan 24, 2021 at 3:53
  • @JamesP - you want to boot it in single user mode. Details here osxdaily.com/2018/10/29/boot-single-user-mode-mac
    – kindjacket
    Commented Jan 24, 2021 at 4:18
  • Thanks @kindjacket, totally worked. Again, a roland driver was the culprit
    – James P
    Commented Jan 24, 2021 at 16:49

if safe mode doesn't work it might be locked with an efi password. try booting up into single user mode(power it on while holding cmd+s) if it loads into a black prompt window run:

fsck -fy

also check if there are any assertions which have been written to /etc/sysctl.cfg some of them might be hindering load due to extra protective kernel parameters which could be enabled. (stuff like vm.cs_library_validation, vm.cs_system_enforcement, vm.cs_process_validation and others ). if there is no sysctl.cfg file, get back here and get me more info so that we can help u out


If you've tried booting into Safe mode by holding Shift then pressing the Power button to turn the machine on, and that didn't help resolve the issue, I would attempt booting into recovery mode.

Hold Cmd + R then press the Power button to turn on the machine. Continue holding Cmd + R until you see the loading bar. It should load into the Recovery Menu.

Open Disk Utility and choose Verify Disk. If that says it needs to be repaired, click the Repair Disk button. If it is still giving errors, then you'd probably be best off taking it to an Apple Store or an AASP (Apple Authorized Service Provider). That way they can run hardware diagnostics on it, and verify that nothing is going on with the actual hardware of the device, like the hard drive.

  1. It appears that your login user has a bad login item or some other snafu that prevents login and safe mode.

    Is your device backed up?

    No, you can copy your data from single user mode or recovery mode to an external device. See below.

  2. Create a new admin. Should be clean of problems with existing user. See below.

  3. install a new copy of macOS on an external drive. The safest move. Before wiping [whipping] startup drive it's best to have two copies of your data.

Get the Mac to set up an additional administrative account.

This will work in all releases of Mac OS X so far.

You need to get into single use mode for steps one and two that are listed below. Start with your computer power off. Hold down command-s. Power on your computer. Continue holding down command-s until you see some text on the screen.

This page will give more details on how to get into single user mode.

Type in the following:

The first two commands will depend on your release of Mac OS X. Look at what is typed out in the console to determine the exact format. You do not need to type in the lines beginning with an ampersand, #, they are comments.

# Type the follow two instructions to access the startup disk in read/write.
# Press return after each command.
# in case of partial success repeat this command until errors go away.

/sbin/fsck -fy
/sbin/mount -uw /

# Get setup to activate a new administration account
cd /var/db
#List all files. The l is a lower case L.
ls -a

# The move command acts as a rename command in this format.
# In Yosemite, this file is zero bytes.
# the disappearance of .AppleSetupDone causes a new administration account
# to be added the next reboot.
mv -i  .AppleSetupDone .AppleSetupDone.old

# reboot  your mac
shutdown -r now

recovering data in single user mode or recovery mode.

Be careful to got the correct path in recovery mode. Your files will not be in /

see: backing up from the command line via single user mode. https://discussions.apple.com/message/32357328#32357328

You may try to recover your data by booting up in recover mode command+r then using the terminal.

You can copy files on the Unix command line interface if you placed the flash drive the USB port before powering on your machine.

1) you best have the flash drive formatted for the Mac. See disk utility. It's on the pull down. 2) Power off the the machine. Hold down the command+r keys then power on your machine. 3) After you specify the language you will come to the installation panel.

4) Do not install.

5) Go to the top of the screen and click on the tools menu item.

6) Click on Terminal to use the command line interface.

7) You can copy files on the Unix command line interface if you placed the flash drive in a USB port before powering on your machine.

ditto -X -rsrc /SSD/users/rastefatah/Desktop/Outlook Festival 2017 RAW files/* /Volumes/thumb

You will note that the path contains spaces. You need to escape all spaces.You need to put quotes around all file names with a space in them. I'm not so sure about the asterisk [ * ]. I think you need to do:

ditto -X -rsrc "/SSD/users/rastefatah/Desktop/Outlook Festival 2017 RAW files" /Volumes/thumb

the ditto command copies over a directory / folder at a time You should verify that the files have been copied correctly by trying them in another Mac before it the deleting the original.

Here is an overview of the commands. https://discussions.apple.com/docs/DOC-11071


I finally find a picture that shows my case. Thanks for all the answer above!But just in case, I want to add another solution I learned from this post Mac Stuck on Loading Screen at Login, How to Fix? to Check and fix user preference settings. Sometimes, the .plist files related to user preferences could be changed. Then, your login information would not be accepted.

hope this helps!


This same things happened to my computer after installing a driver for a Western Digital external drive. It said I needed to restart to finish installation and then my computer wouldn't open past the loading bar. My have a macOS Mojave version 10.14.6

I tried booting my computer with multiple startup options. This list I found as a helpful resource for different key combinations. After trying to Reset PRAM/NVRAM (Cmd + Option + P + R + Power), Reset SMC (Shift + Control + Option + Power), and opening in Target Disk Mode (T + Power) connected to another computer, I found @kindjacket answer above.

Their answer worked for me (opening in Single User Mode (Cmd + S + Power) and then following the commands to create an Unsupported folder will all my extensions). My culprit file was ufsd_NTFS.kext

Would like to note that deleting this file didn't uninstall the driver and I couldn't open the external drive on my computer until I completely uninstalled the software.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .