18

I have been trying to use Sidecar in the public betas of macOS Catalina and iPadOS 13.

I have a 2019 Macbook Pro, and a 3rd generation iPad Pro, so I know I have supported devices.

Both devices are on the same Wifi network, and both have Bluetooth enabled.

Both devices are logged into iCloud with the same AppleID.

Both devices have two-factor authentication enabled.

I have tried this both with and without a USB-C cable connection between the two devices.

The Sidecar preference pane in System Preferences does appear, and when I go into it I can see in the "Select Device" dropdown that my Mac can "see" my iPad Pro.

However, when I try to connect to it, I get the following after a pause:

enter image description here

I keep watching this page for troubleshooting tips, but none have been useful for me thus far.

FWIW, I have been a "good citizen" and reported my problems to Apple via the Feedback Assistant apps on both devices, so in case this is a temporary bug, I've reported it. I'm just asking here in case someone else has encountered this issue.

Edit: Eventually, Sidecar started working for me (sometimes) after some of the later public betas came out. I'm not sure exactly which version(s) of Catalina and/or iPadOS made the difference for me. So far it has worked without any timeouts in the final versions. I didn't need to downgrade and then re-upgrade as the submitted answer suggests, although I'm glad that has worked for some.

10 Answers 10

14

I had this problem setting up a new computer. For me, what fixed it was going into Settings > Accounts > iCloud and checking KeyChain.

It said I needed to update my account security and prompted me with a few security questions. This seems to have indirectly solved the problem; perhaps some minimum standard of security was not upheld and was causing quiet failure.

Unfortunately, I'm guessing that this won't solve everyone's problems as it seems to be a pretty generic message as mentioned above, just thought I'd add my solution to the pile for everyone who's going down the list and trying everything.

4
  • This was the only 'solution' that did the trick for me, thx a lot!
    – z00bs
    Feb 21, 2020 at 15:15
  • I get fixed by following this instruction. Thank you!
    – Quar
    Feb 26, 2020 at 3:38
  • @agarza, Please stop editing ">" to ▶ as aside from the fact it's a needless edit it also shows very clunky on iDevices, etc. Aug 19, 2021 at 17:54
  • This also worked for me, thank you! Feb 15, 2022 at 17:50
8

I suspect that this is a very generic error message and that not everyone who is experiencing it is encountering the same root cause.

I just experienced this error after successfully using Sidecar all day long at work.

After I came home, I logged onto my work's VPN to check on something and, after some amount of time, Sidecar disconnected. When I tried to reconnect it, I got the same "The device timed out" message.

On a hunch, I disconnected from the VPN (in the FortiClient app that my employer requires for VPN access) and Sidecar worked again.

Bottom line: using a VPN can cause this symptom.

1
  • Can confirm that Turning off the VPN solves this isssue for me.
    – narayan
    May 14, 2020 at 11:00
2

I encountered the same hardware and issues. All I had to do was disconnect from VPN (not close) and it works.

  • No restart or anything special.
  • FortiClient as well.
1
  • Welcome to Ask Different!. Please refrain from adding comments in an Answer. The preferred way of saying 'thanks' around here is by up-voting good questions and helpful answers (once you have enough reputation to do so), and by accepting the most helpful answer to any question you ask (which also gives you a small boost to your reputation). Please see the About page and also How to Answer. - From Review
    – fsb
    Feb 12, 2020 at 19:50
2

I had the same problem and I have just solved the problem. Just reinstall the iPadOS13.1 after downgrading to iOS 12.4.

Here is the guide for downgrading. Remember to backup your files, then install ipadOS 13 normally in Settings > General > Software Update.

2
  • Hi, welcome and thanks for the answer! Setting up previous major release.. is it straightforward? Could you link something on how to do it please?
    – anki
    Sep 30, 2019 at 11:01
  • gottabemobile.com/how-to-downgrade-from-ipados-13-to-ios-12 Here is the guid. Remember to backup your files, then install ipados13 normally and.. that's all
    – EnvyVu
    Sep 30, 2019 at 17:26
2

You might try these steps which worked for me:

  1. Create a new, "Standard" user account on your Mac and login to that account.
  2. Reset the trust relationship on your iPad.
  3. Confirm that the connection you plan to use (cable, WiFi, or Bluetooth) is set up correctly on the both the Mac and the iPad.
  4. Connect to the iPad via Sidecar from the new account.
  5. If the connection was successful, login to the previous user account on your Mac. Then connect again to the iPad via Sidecar.
2
  • Without openning a new account, just connecting the iPad with a cable and choosing "trust this computer" fixed my problem. Thank you so much.
    – user3158
    Jul 18, 2022 at 18:58
  • ^This, for me it was that I had Bluetooth disabled on the iPad. Thank you!
    – Mint
    Oct 8, 2023 at 9:26
1

I had the same problem. I signed out from Apple ID in my Mac and signed back in, then tried to mirror the screen to iPad. Now the error was changed to Miscellaneous errors occurred. Then, restarting the Mac fixed the issue.

If the AirPlay icon itself is not displayed, Then we have to make sure below things in both iPad and Mac.

  • Bluetooth is On
  • Connected to same WiFi
  • Connected with same Apple ID account
  • Hand Off is enabled
0
0

I had the same problem and here's what worked for me:

On the iPad go to Settings > Wi-Fi and then chose your Wi-Fi connection and disable the private connection box.

1
  • iPadOS 13 doesn't support private WiFi connections but your answer may help people experiencing the same issue with iOS 14.
    – nohillside
    Dec 27, 2020 at 13:35
0

I was able to fix this by going to System Preferences > Apple ID > iCloud and turning on the Keychain option.

It says it needed to establish an encrypted connection and asked me for some device passwords to complete this step.

This fixed this issue for me.

0

Test turning off the Today View on the iPad.

Go to Settings then Display & Brightness or Home Screen & Dock and toggle off Keep Today View on Home Screen.

0

For me when I clicked on iCloud in settings on the iPad it had new terms and conditions that I needed to accept. After doing that it worked. This wasn't shown with a notification badge until I specifically went to that part of settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .