2

I have an odd situation, I recently purchased an iPhone Xs and for some reason, my older Moto G4 cannot connect to the XS's hotspot.

What puzzles me is that other phones can connect to my Xs without problems, and the moto G4 can connect to other hotspots fine.

I even tried putting my sim card into my friend's iPhone 7 and iPhone 8, just to discard carrier or iOS issues, but the moto G4 connected to those phones immediately.

I've hard reset both phones without success, I changed several times the password and the iPhone XS name but nothing seems to work.

I tried setting passwords with all caps letters, all numbers, all lowercase, 123456789, a mix of both, but it just refuses to connect.

The Moto G4 can connect to 2Ghz and 5Ghz networks so is not a band issue.

The Moto G4 always says authentication failed, but I am 100% confident that the passwords are the same.

I'll appreciate any clues to solve this mystery.

You must log in to answer this question.

Browse other questions tagged .