5

I have been using Calendar for a while and everything was working normally. However, suddenly it stopped showing some events in two of my calendars, and I dont understand why.

I can see all those events on calendar.google.com, but not on Mac calendar.

I've tried:

  1. Refreshing calendars
  2. Ticking on and off the calendars on the left-hand side of the Calendar app
  3. Removing/re-adding the calendar permissions under Accounts.

I dont know how else to fix this. All help is appreciated!

2 Answers 2

5

Indeed, it was a more wide-spread and general issue with Google.

However, I had opened a formal trouble ticket with them, which eventually got recognized, acknowledged, escalated, worked upon and resolved, by about 10:30 am PST 8/23/19.

However, you may need to still purge your calendar cache files:

  • go to calendar.app, go to settings, go to accounts, uncheck the calendar to disable, then quit the calendar application.
  • then, go to your User Library folder ( ~/library/calendars/ folder), (you can easily lookup how to do this if you don't know how to find it)

  • then, delete all items with the name "Cache" in it such as: Calendar Cache-shm Calendar Cache Calendar Cache-wal

  • go back to calendar.app, launch/run it, then, go to settings, go to accounts, check the calendar to re-enable your Google calendar account

  • Then finally, you may wish to also click CMD-R to refresh calendar data and wait for enough time for all data to re-sync

3
  • 1
    This worked for me... but.... If you delete all the Caches, it will also delete subscription calendars (like one-off ICS links), which I struggled to remember how to get back. So just a forewarning, everyone!
    – Rob Latham
    Aug 24, 2019 at 4:44
  • I had the same issue on macOS 11.6 on 2021-09-30. So the root cause of the problem is definitely not fixed yet. This answer helped me solve it. Thanks.
    – tomash
    Sep 30, 2021 at 8:39
  • In my case I had to "force quit" the CalendarAgent from the Activity Monitory in order to pick up the calendar(s) again (before quitting that service the calendar didn't show up in the left bar). Jun 18 at 11:48
2

It is a general issue, not clear if it is on Mac or Google side: https://support.google.com/calendar/thread/12612472?hl=en

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .