1

I (well, my kid) has an old iPad with iOS8 on it. His Apple id has 2FA turned on (he also has an iPhone 5S). Recently we changed his password and now (understandably) iMessage and FaceTime no longer work on the iPad and are prompting for a signin.

I typed in the password and on the phone I get the verification code and on the iPad I get a message saying to type the verification code after the password in the password field.

Since the 5S is showing, say, 123765 as the code, I then type into the password field: ThePassword123765.

However, instead of signing in (or saying it is incorrect) I instead get the "enter verification after your password" prompt. Interestingly, I don't get the notification on the phone so apparently something in the system realized I had indeed typed a code after the password.

But I can't get past this. I just keep getting the enter verification code prompt over and over again. I've also tried getting a code from the Settings app on the phone but the same thing happens.

Also interestingly is that the login to iCloud on the iPad worked fine. I appended the current verification code to the password and logged in. It's just the iMessage and FaceTime logins that are having problems.

Any idea what to try next?

You must log in to answer this question.

Browse other questions tagged .