I'm running the macOS Catalina public beta on a partition of my 2012 MacBook Air. I've been trying to get iCloud Keychain to work (the only thing holding me back from upgrading my main partition), but when I click Set Up it asks me to setup 2FA, then, when I deny (because I don't have an iPhone yet and it would be really annoying) it says "Are you sure?" and then when I say yes it just says "Setting up" which continues for eternity. I've checked on my other device (2011 iMac running High Sierra) and there are no popups or anything. Video of my troubles. I have come up with three hypothesise:

  1. Keychain now requires 2FA
  2. It's a bug
  3. I am being stupid

If it turns out to be the third one, what am I doing wrong? System specs:enter image description here

3 Answers 3


If you see an error like this and cannot continue, one easy fix is to sign out of iCloud and then sign back in.

enter image description here

I'm still perplexed and not sure what ithe dialog wants to Upgrade since my password contains all the correct characters and I already have had two-factor auth on my account since it came out. :D

Also, if the date / time is off, you might check that if you get iCloud errors or can't sign back in once you sign out.

  • I have the same here.
    – herve
    Oct 8, 2019 at 0:00

I tried signing in several times to iCloud, but that didn't work. Also tried force quitting System Preferences, but that failed too.

Eventually signed out of iCloud, signed back in and everything works as it should.

Frustrating problem to have first thing on a morning!


A  > "Force Quit" > "System Preferences" resolved this for.

After that, returning to System Preferences I successfully activated Keychain from the iCloud preference pane:

  • I was apple to login to iCloud,
  • Then I was able to login with my computer password,
  • And finally, I was able to enter one of my devices' passcode.

My Apple ID Settings are updated and my iCloud keychain is working.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .