11

I'm not sure how to explain this. I recently upgraded my iPad. And this thing wasn't happening before. Let me show it with a screenshot:

Say, if I close one app and want to go to the Mail icon. I will try to touch "Mail" (blue one, second from the left) at the bottom row. But right when I'm doing this, that new icon appears on the right (marked with a red arrow) and the whole strip shifts to the left making me click the App store icon instead of Mail.

enter image description here

This is VERY annoying!

How do I stop that icon from appearing on the right?

11

That's the "handoff" feature. You can turn it off at: Settings > General > Handoff.

When you turn it off, that device can't send or receive handoffs. A little bit more info.

enter image description here

You could also use a different iCloud account on your phone/iPad if you wanted handoff to work between a Mac and one device but not both iOS devices, but more than one iCloud is a hassle, so disabling handoff entirely is much cleaner.

  • 5
    Or: get used to it. No interface is going to stay the same indefinitely. Adapting to a certain amount of change and dynamics is going to make life a lot easier. – John Keates Aug 22 at 1:12
  • @Joonas: Oh wow, thank you! Took that bug right out! The question is, how are we supposed to know all this? – c00000fd Aug 22 at 1:17
  • @c00000fd, I think I typically look up new features when major versions come out... That's how I knew. I think asking somebody is a pretty good way to find. Some of these features can be hard to put into words, so googling may not yield results. – Joonas Aug 22 at 5:05
  • 2
    Thank you. This had been bugging me as well after upgrading the iPad last week. I don't mind the handoff feature itself (though I have no use for it), but moving the dock-icons around at the precise moment I'm trying to operate the dock is a major nuisance. – Tonny Aug 22 at 9:14
  • Under normal conditions you would already have a few icons to the right of the dividing line. The handoff icon then only replaces the rightmost icon which does not shift anything. Did you disable “Show Suggested and Recent Apps” in the Dock settings? – szulat Aug 22 at 17:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .