0

I use 2014 model iMac and last year I decided to bootcamp it. After a year I start having hard drive usage issues therefore I uninstalled my bootcamp. But the program couldn't uninstall it properly therefore it left empty space. The disk was deleted somehow. I tried to recover the space with using Disk Utility but now when I use diskutil list I get

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                  Apple_HFS Macintosh HD            999.9 GB   disk0s1

I would like to bootcamp my iMac again but the bootcamp program gives the error:

The startup disk cannot be partitioned or restored to a single partition.

How can I set my Macintosh disk to use the full capacity (1TB)?

I tried using internet recovery but I ended up getting -2002F errors. ( even though I changed my DNS).

Also when I press alt while starting the iMac I still can see the Windows Disk even though i deleted it.

Thank you for your attention.

(here is an image of disk utility) disk utility page

  • Hello, it looks like diskutil list shows that your HD has 999.9 GB. Can you edit your post to show images of your Disk Utility? – existing person Aug 21 at 5:13
  • i added a screenshot – Megu Aug 22 at 2:11
  • I really don't see a problem here... your Apple Hard Drive has 999 gb for your Mac, and the other gb is for recovery I'm guessing. And the reason you see the Windows Disk is probably because you have your USB for WININSTALL still connected. Unless I'm missing something?... correct me if I'm wrong. – existing person Aug 23 at 4:32

You must log in to answer this question.

Browse other questions tagged .