2

Hardware: Macbook Pro 2017 (15")

OS: MacBook Mojave 10.14.6

While using iTerm, I noticed, I could not use alt/option commands with direction keys as I would on my Macbook Pro 2015. This prevents me from navigating around certain CLI utilities. Instead, my iTerm window gets resized as shown below using option+left and option+right. I noticed this is how all application windows behave and not just iTerm. How may I stop this behavior?

Aside: Another weird thing I've noticed on this newer macbook is that cmd + left and cmd + right do not work as Home and End buttons anymore. I now have to use ctrl + a and ctrl + e.

iTerm resize happening with option button

  • 2
    This is not standard macOS behaviour, nor can this be enabled in macOS itself. Check what third-party apps have system-wide access to window manipulation in System Preferences → Security & Privacy → Privacy → Accessibility — try disabling suspect apps and attempting the shortcut again. – grg Aug 20 at 17:35
  • Suspicious apps I have include Spectacle and Karabiner – Joseph Rex Aug 20 at 17:48
  • Thanks for helping me narrow it down. It turned out this was all being caused by Slate. Maybe add your comment as an answer so I can upvote it? – Joseph Rex Aug 20 at 18:37
  • 1
    Glad you've got it sorted, I've added an answer! – grg Aug 20 at 18:39
  • 1
    For anyone else that may experience this with Slate, here's another post that addresses it apple.stackexchange.com/questions/133131/… – Joseph Rex Aug 20 at 18:48
2

Since this is not standard macOS functionality, neither default nor optional, this is either functionality added by you (or someone acting as administrator) or a third-party app.

You can check what third-party apps have system-wide access to window manipulation in System Preferences → Security & Privacy → Privacy → Accessibility. One by one, try disabling suspect apps and attempting the shortcut again.

When you've narrowed down the specific app, you can either disable the app or research the possibility of changing/disabling the offending shortcut.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .