0

I logged in as the root user so that I could pull all the files from all users into one folder to then transfer to an external hard drive. I had no problem moving files to the root user desktop but trying to move, copy, or even delete files from the desktop results in a “preparing to move” dialog box that shows no progress even when trying to simply move an empty test folder.

I feel like this may be because of some error in permissions because the root user desktop is located in /macintosh hd/private/var/root/desktop/ and the private folder is hidden.

How do i get around this issue?

2
  • Can you add some details about the access rights of the folders and files in question, and about the Desktop folder? – nohillside Aug 20 '19 at 5:52
  • Also, there might be easier ways to solve the original problem, but it might be better to ask a separate question for this. – nohillside Aug 20 '19 at 5:53
1

Not sure why it was happening but i found a work around using terminal “sudo mv ...” command to manually move the folders

1
  • If you originally copied/moved the files while logged in as root then you have to either continue to process the files logged in as root or use sudo, that's just the way it is with permissions in this use case. – user3439894 Aug 21 '19 at 1:09
-2

I think you might run into a System Integrity Protection (SIP) problem: disable sip: boot from recovery partition, open terminal, execute "csrutil disable", reboot -> try again.

Root accounts on macos are not the godmode (anymore) they are on other Unix style machines.

3
  • The OP's issue has absolutely nothing to do with SIP! The OP was originally logged in as root when copying other User files to the Desktop under root and therefore either continue to process the files logged in as root or use sudo, that's just the way it is with permissions in this use case. – user3439894 Aug 21 '19 at 1:12
  • I have the same problem. I have it on more than one Mac. I’ve used the same workaround. It seems to me that the Finder is somehow restricted when working with items on the root desktop when logged in as root. I would surely like to know what to do to change it. I keep SIP disabled. – Trellis Feb 26 '20 at 11:43
  • I even went so far as to let the system refurbish the root home folder default contents by running “rm -r /var/root/*”, then rebooting and logging in as root again. I could still copy items to the root desktop, but continued to see the persistent “preparing” alert when I tried to copy or remove them from the desktop. – Trellis Feb 26 '20 at 11:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .