2

I have several Apple devices and all are connected to the iCloud. My iMac however will not download any files from the cloud, it is an empty file! I have done the following.

  • Signed out and back into my iCloud account.
  • Restarted.
  • unchecked the sync button and rechecked.

What can I do?

  • Hi, welcome! Uncheck optimise storage in iCloud options in System Preferences. Check internet connection, though sign out and in leaves no doubt, but still. Firewall? apple.stackexchange.com/questions/157862/… <- this says that it's just slow. Maybe other processes are hogging bandwidth. Check for that in Activity Monitor. What is OS version btw? – ankii Aug 19 at 14:40
  • Internet is working well but I can't see optimize storage anywhere /Users/paulmiller/Dropbox/Screenshots/Screenshot 2019-08-19 09.51.50.png – POP Aug 19 at 14:54
  • You can use imgur.com for. screenshots. Go to system Preferences-> iCloud -> iCloud Drive options -> bottom is optimisation. Did you see activity monitor -> network tab for any heavy usage? Also what is your icloud storage? More data will take more time to download. – ankii Aug 19 at 18:27
  • Mine does not have the option to optimize storage on this IMac. My macBook Pro does. – POP Aug 20 at 14:26

You must log in to answer this question.

Browse other questions tagged .