0

I'm having a big issue when copying from multiple Excel cells/rows and then pasting into a Keynote/Numbers table. When I select multiple cells in Excel with named content such as 'David goes to the gym' and then paste into a Keynote/Numbers cell it stretches the content across 5 separate cells as opposed to keeping it in one cell.

I have absolutely no idea why this is happening.. I've reinstalled office365 but this hasn't changed anything.

Anyone any ideas on this ?

  • Firstly, welcome to Ask Different! :) I hope you find this site has a lot to offer! In case you haven't already, it's worth taking the time to read the tour. As for your question, can you clarify exactly what you mean by a keynote/numbers cell? Do you mean you're trying to paste it into a Numbers spreadsheet, a Keynote table, or a Keynote table that you originally copied and pasted from a Numbers spreadsheet? Also, can you clarify what you mean by named content in Excel? Do you mean you're copying a named range, or just that you're copying text? – Monomeeth Aug 19 at 11:02
  • Hey, thanks for the welcome and apologies if the question was unclear. I meant a table in a numbers or keynote file. Also there's simply text in a multiple rows and when I copy these and input it into the table in either keynote or numbers it's spreading the content across multiple cells, so if in the excel file the column/row read 'David asked a question' then I pasted into the keynote/numbers table it would paste across 4 columns like A - David, B - asked, C - a, D - question, and so on.. Hope this makes sense... – David Okten Aug 19 at 16:43
1

Your delimiter in numbers is set to a 'space', so it reads spaces in the sentence as being cell delimiter. Hence, each word goes into a separate cell. You need to change the delimiter to a comma or a tab. Then only values separated this chacter will fill new cells. To change delimiter (taken from question):

In Numbers you can use any separator when importing csv tables.

On the format sidebar, in the table tab, look for adjust Import settings. Inside it you have delimited options where you can even use custom delimiters

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .